Bug 143287 - Postfix chroot env doesn't refresh libs on upgrade, causing core dump in smtp process
Postfix chroot env doesn't refresh libs on upgrade, causing core dump in smtp...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 21:01 EST by Jeff Pitman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 07:04:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Pitman 2004-12-17 21:01:49 EST
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML,  
like Gecko)  
  
Description of problem:  
After executing an apt-get dist-upgrade from FC2 to FC3, everything  
worked except postfix. The /var/spool/postfix/lib libraries did not  
get upgraded from the FC2 versions to the FC3 versions.  This caused  
the smtp process to core dump as it was processing the mail queue  
going to external email addresses. Even "ls" would core dump if you  
cd /var/spool/postfix/lib and try to execute it.  This probably is  
connected with the nss stuff resolving uid, etc.  
 
For googlers, the log associated with this is: 
Dec 16 15:50:26 kubik postfix/qmgr[4839]: warning: premature 
end-of-input on private/smtp socket while reading input attribute 
name 
Dec 16 15:50:26 kubik postfix/qmgr[4839]: warning: private/smtp 
socket: malformed response 
Dec 16 15:50:26 kubik postfix/qmgr[4839]: warning: transport smtp 
failure -- see a previous warning/fatal/panic logfile record for the 
problem description 
Dec 16 15:50:26 kubik postfix/master[4834]: warning: 
process /usr/libexec/postfix/smtp pid 4847 killed by signal 11 
Dec 16 15:50:26 kubik postfix/master[4834]: 
warning: /usr/libexec/postfix/smtp: bad command startup -- 
throttling 
 
  
How reproducible:  
Didn't try  
  
Steps to Reproduce:  
  
1. Start with FC2 install.  
2. Upgrade to FC3's version of postfix.  
      
  
Actual Results:  Skips update to /var/spool/postfix/lib  
  
Expected Results:  Properly update /var/spool/postfix/lib when a  
version difference is detected between system libs and chroot libs.
Comment 1 Thomas Woerner 2004-12-20 07:04:18 EST
You made that changeroot, so you have to updates it per hand.
This is not a bug.

Note You need to log in before you can comment on or make changes to this bug.