Bug 143317 - rpm failed to download from ftp if wget is not installed
rpm failed to download from ftp if wget is not installed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-18 15:07 EST by Rahul Sundaram
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-29 00:56:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2004-12-18 15:07:19 EST
Description of problem:
rpm failed to download from ftp if wget is not installed



Version-Release number of selected component (if applicable):

rpm-4.2.3-10

How reproducible:

everytime


Steps to Reproduce:
1. remove wget and do rpm -ivh ftp://ftplocation/rpmfile

Actual results:

fails with unknown error

Expected results:

should detect and request the user to install wget

Additional info:

probably better to specify a runtime dependency on wget if thats optimal
Comment 1 Jeff Johnson 2004-12-29 00:56:36 EST
rpm has an internal ftp client and does not use wget. Something
else is wrong.

Note You need to log in before you can comment on or make changes to this bug.