Bug 143354 - tetex rebuild
tetex rebuild
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 16:46 EST by Florian La Roche
Modified: 2013-07-02 19:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 10:18:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Compile log with gcc-3.4.3-10 (354.69 KB, patch)
2004-12-20 06:41 EST, Jindrich Novy
no flags Details | Diff
Patch to fix some broken dependencies in tetex (1.81 KB, patch)
2005-01-07 05:31 EST, Jindrich Novy
no flags Details | Diff

  None (edit)
Description Florian La Roche 2004-12-19 16:46:37 EST
Description of problem:

Rebuilding tetex with current Fedora Core development tree gives:

make[1]: Entering directory
`/home/build/rebuild/build/tetex-2.0.2-26.src.rpm/te
tex-src-2.0.2/texk/web2c/ptex-src-3.1.4'
gcc -O2 -g -pipe -D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4
    ../../
kpathsea/kpsewhich.c ../../kpathsea/libkpathsea.la ../lib/lib.a
../../kpathsea/l
ibkpathsea.la -lm    -o ../../kpathsea/kpsewhich
/usr/bin/ld:../../kpathsea/libkpathsea.la: file format not recognized;
treating
as linker script
/usr/bin/ld:../../kpathsea/libkpathsea.la:1: syntax error
collect2: ld returned 1 exit status
make[1]: *** [../../kpathsea/kpsewhich] Error 1
make[1]: Leaving directory
`/home/build/rebuild/build/tetex-2.0.2-26.src.rpm/tet
ex-src-2.0.2/texk/web2c/ptex-src-3.1.4'
make: *** [ptex-euc.fmt] Error 2



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jindrich Novy 2004-12-20 06:39:57 EST
Hi Florian,

I was unable to reproduce this with:
gcc-3.4.2-6.fc3

and latest devel gccs:
gcc-3.4.3-10.i386.rpm
and
gcc4-4.0.0-0.15.i386.rpm

even if I try to add -D_FORTIFY_SOURCE=2 to CFLAGS.

Could you please check what's inside of the libkpathsea.la? It should
contain only a compilation date such as Mon Dec 20 11:33:47 CET 2004.
Comment 2 Jindrich Novy 2004-12-20 06:41:35 EST
Created attachment 108885 [details]
Compile log with gcc-3.4.3-10
Comment 7 Jindrich Novy 2005-01-07 05:31:01 EST
Created attachment 109457 [details]
Patch to fix some broken dependencies in tetex

I've done more dependency fixes in tetex makefiles, it should work fine now
with -j16 for instance.

Note You need to log in before you can comment on or make changes to this bug.