Bug 143364 - kernel: serial8250: too much work for irq4
kernel: serial8250: too much work for irq4
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 18:43 EST by bastiaan
Modified: 2015-01-04 17:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2004-12-19 18:43:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041003
Firefox/0.10

Description of problem:
When using the serial port to communicate with the TowiToko Chipdrive
smartcard interface, the kernel logs repeatedly 'serial8250: too much
work for irq4' to syslog and communication to the smartcard interface
fails.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667, kernel-2.6.9-1.685_FC3, kernel-2.6.9-1.715_FC3

How reproducible:
Always

Steps to Reproduce:
1. install pcsc-lite, pcsc-lite-tools and the towitoko smartcard driver
2. run /usr/bin/scriptor


    

Actual Results:  The kernel logs 'serial8250: too much work for irq4'
and the PCSC driver daemon complains about driver initialization failure.


Expected Results:  The driver should initialize properly: the same
pcsc-lite and towitoko driver revisions do function properly on
another system running FC2.

Additional info:

The smartcard interface communicates with 9600 bps.
The serial port appears to function properly to other serial devices
at even higher speeds (115kbps) with for example minicom, I've not
been able to reproduce the 'too much work' message with other serial
port usage than the towitoko smartcard interface. 
Oddly enough, problem does not appear when one first disconnects the
smartcard interface, starts up and quits minicom reconnects the
smartcard interface and then starts pcsc daemon.

The computer is a Toshiba Stallite 4090CDS with 400MHz Intel Celeron
and, according to the 8250/16550 serial driver a 16550A UART. 

cat /proc/interrupts:
           CPU0
  0:   34854959          XT-PIC  timer
  1:          8          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:      27082          XT-PIC  xirc2ps_cs
  4:        491          XT-PIC  serial
  8:          1          XT-PIC  rtc
 11:         14          XT-PIC  ESS Maestro, uhci_hcd, yenta, yenta
 12:         66          XT-PIC  i8042
 14:     112890          XT-PIC  ide0
 15:     312764          XT-PIC  ide1

cat /proc/ioports:
           CPU0
  0:   34854959          XT-PIC  timer
  1:          8          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:      27082          XT-PIC  xirc2ps_cs
  4:        491          XT-PIC  serial
  8:          1          XT-PIC  rtc
 11:         14          XT-PIC  ESS Maestro, uhci_hcd, yenta, yenta
 12:         66          XT-PIC  i8042
 14:     112890          XT-PIC  ide0
 15:     312764          XT-PIC  ide1
Comment 1 Dave Jones 2005-07-15 15:14:08 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 bastiaan 2005-07-18 03:06:49 EDT
Thanks for the update. (Un)fortunately I don't have the mentioned laptop in my
posession anymore, and the newer replacement laptop does not exhibit the
problem. So, at the moment I cannot give feedback on the update.
Comment 3 bastiaan 2005-07-18 03:10:16 EDT
hmm, I appear to have accidentally modified status to 'assigned': resetting to
'needinfo'. Sorry.
Comment 4 Dave Jones 2005-07-29 20:42:59 EDT
ok, thanks for the update.
Comment 5 Kasper Dupont 2005-10-01 09:22:23 EDT
I have been seeing this message in my log since I upgraded from FC2 to FC4
(except in my case it says irq10 rather than irq4). I rarely use the serial port
though, so I don't know if it is working or not.
Comment 6 Kasper Dupont 2006-10-01 01:13:13 EDT
This problem also exist in kernel-2.6.17-1.2187_FC5
Comment 7 Kasper Dupont 2006-10-17 10:56:52 EDT
Seen in kernel-2.6.18-1.2200.fc5, will somebody please update version?
Comment 8 Christian Kujau 2010-04-11 05:00:32 EDT
This is still an issue in FC13-Beta.RC5 when booting e.g. -netinst.iso with console=ttyS0,115200n8 - The console works though, the log is just spammed with these messages whenever lot's of output is written to ttyS0.

Note that this happens within a VirtualBox VM:

http://www.virtualbox.org/ticket/2752
http://kerneltrap.org/mailarchive/linux-kernel/2008/2/5/735714
Comment 9 purpleidea 2012-02-17 16:10:22 EST
FWIW: I get this message on my serial console on kvm/centos6.2 with centos6.2 guest.

Note You need to log in before you can comment on or make changes to this bug.