This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 143375 - Easytag fails to open - undefined symbol
Easytag fails to open - undefined symbol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: easytag (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 21:27 EST by Carl Gherardi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 11:53:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Gherardi 2004-12-19 21:27:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041212 Firefox/1.0

Description of problem:
Running fedora rawhide - looks like easytag broke with the last round of updates that included the id3 lib.

Version-Release number of selected component (if applicable):
easytag-0.31-1 id3lib-3.8.3-9

How reproducible:
Always

Steps to Reproduce:
1. Start easytag from cli

Actual Results:  [carlos@coeus ~] easytag &
[1] 18529
[carlos@coeus ~] easytag: symbol lookup error: /usr/lib/libid3-3.8.so.3: undefined symbol: _ZNSs4_Rep20_S_empty_rep_storageE

Additional info:
Comment 1 Marius L. Jøhndal 2004-12-20 05:15:05 EST
This sounds a little strange, as AFAIK easytag-0.31-1 was built with
id3lib-3.8.3-9 installed.

Unfortunately I don't have access to any Linux system at the moment, so I won't
be able to look into it before Christmas day.
Comment 2 Michael Schwendt 2004-12-20 06:21:57 EST
FC3: Cannot reproduce.

Since id3lib is a C++ library, is Rawhide still ABI compatible with FC3?
Comment 3 Matthias Saou 2005-01-31 11:53:32 EST
Same here, can't reproduce on FC3, and as current pre-Extras packages
are built against FC3, I'm closing as NOTABUG. If there is indeed a
problem regarding id3lib and what will become FC4, then it'll be
resolved when Extras get rebuilt against FC4.

Note You need to log in before you can comment on or make changes to this bug.