This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1434 - ether_ntoa doesn't use static buffer for return value
ether_ntoa doesn't use static buffer for return value
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-05 18:35 EST by stanonik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-15 18:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description stanonik 1999-03-05 18:35:52 EST
ether_ntoa returns junk because it doesn't declare its
buffer as static, so the return value is overwritten by
the next call of any kind  Adding static fixes the
problem

In glibc/inet/ether_ntoa.c, add static

char *
ether_ntoa (const struct ether_addr *addr)
{
  static char asc[18];

  return ether_ntoa_r (addr, asc);
}
Comment 1 Jeff Johnson 1999-05-15 18:11:59 EDT
This problem has been fixed in glibc-2.1.1-6.

Note You need to log in before you can comment on or make changes to this bug.