Bug 143409 - libsoup-devel requires libgcrypt-devel and gnutls-devel
libsoup-devel requires libgcrypt-devel and gnutls-devel
Product: Fedora
Classification: Fedora
Component: libsoup (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
Depends On:
  Show dependency treegraph
Reported: 2004-12-20 09:45 EST by Adrian Reber
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-28 10:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adrian Reber 2004-12-20 09:45:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
when compiling gtkhtml3 it aborts with following error:

gcc -DICONDIR=\"/usr/local/share/gtkhtml-3.1/icons\" -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1 -g -O2 -Wall -Wmissing-prototypes -o .libs/testgtkhtml testgtkhtml.o htmlurl.o  ./.libs/libgtkhtml-3.1.so -L/usr/X11R6/lib -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnome-2 /usr/lib/libpopt.so -lbonobo-2 -lgconf-2 -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lgthread-2.0 -lgnomeprintui-2-2 -lgnomeprint-2-2 -lglade-2.0 /usr/lib/libgailutil.so -lgnomecanvas-2 -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lsoup-2.2 -lgnutls -lgcrypt -lgpg-error /usr/lib/libxml2.so -lpthread -lz -lm -lglib-2.0 -Wl,--rpath -Wl,/usr/local/lib
/usr/bin/ld: cannot find -lgnutls
collect2: ld returned 1 exit status
make[2]: *** [testgtkhtml] Error 1
make[2]: Leaving directory `/tmp/gtkhtml-3.3.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/gtkhtml-3.3.2'
make: *** [all] Error 2

The dependency on gnutls comes from /usr/lib/pkgconfig/libsoup-2.2.pc:
Libs: -L${libdir} -lsoup-${SOUP_API_VERSION} -lz -L/usr/lib -lgnutls -lgcrypt -lgpg-error -lxml2 -lpthread -lz -lm

A line in the devel section of libsoup.spec containing:
Requires: libgcrypt-devel gnutls-devel

should fix it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. compile something which requires libsoup-devel

Additional info:
Comment 1 Adrian Reber 2005-11-28 10:11:34 EST
I am closing this bug as this has been fixed in January 2005.

Note You need to log in before you can comment on or make changes to this bug.