Bug 143462 - ValueError: invalid literal for long(): %{epoch}
ValueError: invalid literal for long(): %{epoch}
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 01:04 EST by james
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 21:14:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2004-12-21 01:04:49 EST
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; Linux i686; U)  [en]

Description of problem:
yum -y update
.
.
.
--> Processing Dependency: libdb_cxx-4.2.so for package: xca
--> Processing Dependency: ghex= %{epoch}:2.8.0-2 for package: ghex-
devel
Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 104, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 174, 
in buildTransaction
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 187, 
in resolveDeps
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 268, 
in _processReq
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 417, 
in _requiringFromTransaction
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 65, 
in whatProvides
  File "/usr/lib/python2.3/site-packages/rpmUtils/miscutils.py", line 
304, in stringToVersion
  File "/usr/lib/python2.3/string.py", line 236, in atol
    return _long(s, base)
ValueError: invalid literal for long(): %{epoch}


Version-Release number of selected component (if applicable):
yum-2.1.12-1

How reproducible:
Always

Steps to Reproduce:
1.yum -y update
2.
3.
    

Actual Results:  ValueError: invalid literal for long(): %{epoch}

Expected Results:  Complete

Additional info:

large number of packages to update
Comment 1 Seth Vidal 2005-01-20 21:14:03 EST
fixed in upstream cvs - will be out in 2.1.13

Note You need to log in before you can comment on or make changes to this bug.