Bug 143485 - Hangs while "Initializing Hardware..."
Hangs while "Initializing Hardware..."
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 10:46 EST by Damon Chaplin
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-24 23:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damon Chaplin 2004-12-21 10:46:37 EST
I just did a fairly basic install of FC3 alongside Windows ME on my
Toshiba 2805-S402 laptop. (FC2 worked fine on this laptop.)

Unfortunately it hangs when booting, right after:

     Starting udev:
     Initializing hardware... storage network audio

(The laptop has an nVidia GeForce 2 Go chip, if that matters.)
Comment 1 Damon Chaplin 2004-12-21 17:26:21 EST
Actually I didn't have FC2 on the laptop before. I think it was RH9.

I just tried FC2 and it booted, but when it did the initial sound
test the sound wasn't correct (much too slow and choppy) and sound
was turned off.

So I suspect a problem with the sound chip. It is reported as a
Yamaha YMF-754. I think the snd-ymfpci module was used.

Is there a boot option to skip the sound setup?
Comment 2 Sitsofe Wheeler 2004-12-22 04:47:50 EST
If you edit grub and remove "rhgb" does it get further?
Comment 3 Damon Chaplin 2004-12-22 06:37:09 EST
No, it stops at exactly the same place.
Comment 4 Marcin Wołyniak 2005-01-09 04:46:07 EST
The same effect on fresh install of FC3 on old Dell Latitude 500GX.
Previously installed FC2 worked. After installation, on firstboot conf
reboot it hangs at exactly same stage. I commented out the whole
section on initializing hrdwr in rc.sysinit and it startup goes further. 
Comment 5 Marcin Wołyniak 2005-01-09 05:20:03 EST
Additional news: only audio section hangs the computer. Command
`modprobe snd-nm256' hangs with following text: PCI: Enabling device
0000:01:00.1 (0000 -> 0002). Any ideas?
Comment 6 Marc BOZENKO 2005-02-04 08:57:54 EST
The same effect on fresh install of FC3 on an EPIA M10000.
Comment 7 Dave Jones 2005-02-13 00:06:55 EST
any better with the latest updates ?  Are you using NVIDIA's driver ?
Comment 8 Damon Chaplin 2005-06-22 13:46:23 EDT
This seems to be fixed in FC4. It now boots up fine on my laptop.

Note You need to log in before you can comment on or make changes to this bug.