Bug 14350 - incorrect file and directory permissions (reported by linuxconf)
Summary: incorrect file and directory permissions (reported by linuxconf)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 13617 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-21 00:39 UTC by John Cagle
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-27 12:37:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Cagle 2000-07-21 00:39:30 UTC
3 files and 1 directory are installed with incorrect permissions (at least they don't
match what linuxconf thinks they should be.)

To reproduce:
--------------------
After a fresh beta3 installation, reboot and run linuxconf.
Don't change anything, just quit linuxconf and look at the
changes it wants to make.

Here are the files BEFORE running Linuxconf:

-rw-------    1 root     root          603 Jul  7 12:15 /etc/shadow
-r-sr-xr-x    1 root     root       372340 Jul  4 01:16 /usr/sbin/sendmail
drwxr-xr-x    2 root     mail         4096 Jul  7 12:27 /var/spool/mqueue
-rwxr-xr-x    1 root     root       143676 Jun  5 15:51 /usr/sbin/pppd

First time run of linuxconf after installation says:

Changing permissions  of file /etc/shadow from 100600 to 100400
Changing permissions  of file /usr/sbin/sendmail from 104555 to 106755
Changing owner of file /var/spool/mqueue to root.root
Changing permissions  of file /usr/sbin/pppd from 100755 to 104755
Changing owner of file /var/spool/uucp to uucp.root

AFTER linuxconf applies the changes:

-r--------    1 root     root          603 Jul  7 12:15 /etc/shadow
-rwsr-sr-x    1 root     root       372340 Jul  4 01:16 /usr/sbin/sendmail
drwxr-xr-x    2 root     root         4096 Jul  7 12:27 /var/spool/mqueue
-rwsr-xr-x    1 root     root       143676 Jun  5 15:51 /usr/sbin/pppd

Comment 1 Michael Fulbright 2000-07-21 15:09:31 UTC
This is not an installer issue.

Comment 2 Glen Foster 2000-07-21 18:29:43 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 3 Nalin Dahyabhai 2000-07-21 22:49:59 UTC
Except for /etc/shadow (which I think would probably benefit from
being read-only for root), all of these permissions should match the
installed system as of linuxconf-1.19r1-7 and later (beta 4).  Please
reopen this bug if you find this continues to be a problem.

Comment 4 John Cagle 2000-07-22 00:22:12 UTC
You are correct.  On beta4 everything cleared up except /etc/shadow.

So, I'd like to re-open this bug so that /etc/shadow can have the
proper permissions post-install.  They should be 100400, not 100600.

Should the bugzilla category change?

Comment 5 Nalin Dahyabhai 2000-07-23 20:55:15 UTC
Probably, but there are enough packages that modify that file to make
it hard to guess which one it's best filed against.

Comment 6 Tim Waugh 2000-07-27 12:37:43 UTC
*** Bug 13617 has been marked as a duplicate of this bug. ***

Comment 7 Trond Eivind Glomsrxd 2000-09-13 22:40:19 UTC
this should be fixed in the final release.


Note You need to log in before you can comment on or make changes to this bug.