Bug 143513 - up2date broken on x86-64 systems.
up2date broken on x86-64 systems.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 14:59 EST by Tim Skirvin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.4.69
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 18:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Skirvin 2004-12-21 14:59:45 EST
Description of problem:  

up2date does not work on x86-64 systems.  Not only can I not install
new security patches, but old ones do not install either.


Version-Release number of selected component (if applicable):


How reproducible:

Every time.


Steps to Reproduce:
1./usr/bin/up2date --nox --update 

Actual results:

Invalid group id server-cfg

Fetching Obsoletes list for channel: rhel-x86_64-desktop-3...

Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------
ImageMagick                             5.5.6          7             
   x86_64
ImageMagick-perl                        5.5.6          7             
   x86_64
XFree86                                 4.3.0          78.EL         
   x86_64
[...]
xscreensaver                            4.10           8             
   x86_64
ypbind                                  1.12           5.21.1        
   x86_64
zip                                     2.3            16.1          
   x86_64


Testing package set / solving RPM inter-dependencies...
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy
dependencies:
Name                                    Version        Release
--------------------------------------------------------------
compat-db                               4.0.14         5.1           
     

file /usr/share/java/libgcj-java-placeholder.sh from install of
libgcj-3.2.3-47 
conflicts with file from package libgcj-3.2.3-42
file /usr/share/man/man1/gij.1.gz from install of libgcj-3.2.3-47
conflicts with
 file from package libgcj-3.2.3-42
file /usr/share/man/man1/gjar.1.gz from install of libgcj-3.2.3-47
conflicts wit
h file from package libgcj-3.2.3-42
file /usr/share/man/man1/grepjar.1.gz from install of libgcj-3.2.3-47
conflicts 
with file from package libgcj-3.2.3-42
file /usr/share/man/man1/grmic.1.gz from install of libgcj-3.2.3-47
conflicts wi
th file from package libgcj-3.2.3-42
file /usr/share/man/man1/grmiregistry.1.gz from install of
libgcj-3.2.3-47 confl
icts with file from package libgcj-3.2.3-42
file /usr/share/man/man1/jv-convert.1.gz from install of
libgcj-3.2.3-47 conflic
ts with file from package libgcj-3.2.3-42



Expected results:

[successfull up2date run]


Additional info:

I have this working on our 32-bit systems without any problems. 
64-bit systems worked until today.  

The above information is from a freshly installed system.
Comment 2 Mark J. Cox (Product Security) 2004-12-22 03:53:51 EST
I'm removing severity "security" since you can work around this by
just using up2date and naming the particular packages you want to
download, or adding libgcj to your exclusion list for now.  
Comment 3 Adrian Likins 2005-01-11 12:57:32 EST
All known issues related to multilib dep solving should be
solved with the version in U4.

Note You need to log in before you can comment on or make changes to this bug.