Bug 14352 - bad tixwish binary and filename (tix package)
Summary: bad tixwish binary and filename (tix package)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard: ISSUE0000187673
Keywords:
Depends On:
Blocks: 13757
TreeView+ depends on / blocked
 
Reported: 2000-07-21 01:16 UTC by John Cagle
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 22:13:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Cagle 2000-07-21 01:16:24 UTC
Two problems:

1) The tixwish binary, /usr/bin/tixwish4.1.8.3, should be called /usr/bin/tixwish (see tixwish man page).
2) The tixwish binary segfaults.

To reproduce:

* Install Redhat 7.0 Beta 3 with the tix package (this is a standard install).
* Now cd /usr/lib/tix4.1/demos. This is a location of a sample script called widget.

* ERROR #1: When invoking ./widget, the script is rejected because there is not tixwish (exec: tixwish not found).
This is easy to fix, though, so rename /usr/bin/tixwish4.1.8.3 to /usr/bin/tixwish.

* ERROR #2: Now re-invoke ./widget, and the script causes a segmentation fault.

Comment 1 Glen Foster 2000-07-21 18:30:04 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 John Cagle 2000-07-24 22:00:45 UTC
Not fixed in beta4.

Comment 3 John Cagle 2000-07-27 22:36:56 UTC
Not fixed in pinstripe (beta 5).

Comment 4 Jeff Johnson 2000-07-27 22:44:44 UTC
Um, the package didn't change between beta4 and beta5 either, as tcltk was not
rebuilt
because of a mis-compiled col. I have later packages if you are willing to
check,
send me <jbj@redhat.com> mail privately and I'll send you the packages.

Comment 5 Jeff Johnson 2000-08-03 20:55:48 UTC
Fixed in tcltk-8.3.1-44 AFAIK. Please reopen if not.

Comment 6 John Cagle 2000-08-03 22:22:38 UTC
I installed all the new RPMs you emailed me, and tixwish now seems to work.

However, I got these errors during the "rpm -Uvh" of the RPMs:

# rpm -Uvh *
expect                      ##################################################
itcl                        ##################################################
tcl                         ##################################################
tcllib                      ##################################################
tclx                        ##################################################
tix                         ##################################################
/sbin/ldconfig: Input file /usr/lib/libtixsam.so not found.

tk                          ##################################################
/sbin/ldconfig: Input file /usr/lib/libtixsam.so not found.

/sbin/ldconfig: Input file /usr/lib/libtixsam.so not found.

# l /usr/lib/libtixsam.so
lrwxrwxrwx    1 root     root           19 Aug  2 15:03 /usr/lib/libtixsam.so -> libtixsam4.1.8.3.so

# file /usr/lib/libtixsam.so
/usr/lib/libtixsam.so: broken symbolic link to libtixsam4.1.8.3.so

Are these errors OK??

Comment 7 John Cagle 2000-08-08 22:13:52 UTC
Do the ldconfig errors during RPM install indicate any problems?

Comment 8 Jeff Johnson 2000-08-09 13:22:56 UTC
No they do not indicate an important problem. There's a symlink in the package
to a
library that has been removed, the symlink has been removed as well in a later
version
of the package (You can do the same using /bin/rm on the symlink).


Note You need to log in before you can comment on or make changes to this bug.