Bug 143551 - mysql compile-time error
mysql compile-time error
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 03:07 EST by Piyaphan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 11:16:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piyaphan 2004-12-22 03:07:05 EST
Description of problem:

I couldn't compile MySQL 4.0.23 RPM Source.
It shows me like this...

In file included from item.h:490,
                 from mysql_priv.h:312,
                 from table.cc:20:
item_timefunc.h:219: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[4]: *** [table.o] Error 1
make[4]: Leaving directory `/usr/src/redhat/BUILD/mysql-4.0.23/sql'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/mysql-4.0.23/sql'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/mysql-4.0.23/sql'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/mysql-4.0.23'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.81193 (%build)


How to fix it?
Comment 1 Tom Lane 2004-12-22 10:29:51 EST
Reassigning as gcc issue.
Comment 2 Jakub Jelinek 2004-12-22 11:16:49 EST
When the bug is not reproducible, as GCC found out, this is not GCC bug, but
in all cases I saw so far it always has been because of flakey hardware.
When GCC driver sees a segfault or other other internal error of the backend,
it retries two more times to check reproduceability.  If it is reproduceable,
it prompts you to file a bugreport and prepares preprocessed testcase for that.

Note You need to log in before you can comment on or make changes to this bug.