Bug 143557 - Microsoft Natural Keyboard PS/2 does not function.
Microsoft Natural Keyboard PS/2 does not function.
Status: CLOSED DUPLICATE of bug 142639
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-12-22 04:24 EST by rob versluis
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-06 18:35:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description rob versluis 2004-12-22 04:24:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After upgrading from FC1 to FC3 the MS Natural keyboard does not
funktion anymore on a Dell Optiplex Gx60 Celeron.
I have to use the original Dell keyboard on this machine.
It has nothing todo with X while in terminal mode it also won't funktion.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. plug in the MS Natural keyboard
2. boot FC3
3. keyboard does function with the grub menu but after kernel load
it's dead.

Actual Results:  Not possible to do keyboard input.

Expected Results:  Normal keyboard behavoour.

Additional info:
Comment 1 rob versluis 2004-12-22 05:00:34 EST
Correction on hardware: Dell Optiplex Gx260 P4 2.4 GHz
Comment 2 rob versluis 2005-01-26 02:12:16 EST
Kernel 2.6.10-1.741_FC3 did not fix the problem.

The keyboard is connected directly.
Also the X-Windows starts with a flattering screen...
Directly after booting the MS Natural keyboard does not function
anymore; after releasing the left shift all lights flashes one time.

Comment 3 Eido Inoue 2005-01-26 11:05:35 EST
Tested with that keyboard on FC3; I do not have a Optiplex Gx260-- but
I did test on another Dell.

Perhaps your X has the keyboard configured incorrectly? Does the
keyboard work in console/text mode?
Comment 4 Eido Inoue 2005-01-26 11:08:02 EST
Comment 3: I am aware that you said "it won't work in terminal mode",
but I'm not sure if you meant terminal in X or the real console.

Regardless, the keyboard works for me with the current FC3 kernel.
Comment 5 rob versluis 2005-01-26 11:31:54 EST
Without starting X, run level 3, the keyboard do not function.
In the Grub screen I can use it, but after kernel load it is all over.
Comment 6 Eido Inoue 2005-01-26 12:26:56 EST
shrug. don't really know how to trace this down... as I'm not
experiencing the problem over here. Additionally, if you are having
the problems in both X and the console, this isn't a kbd component
problem (X doesn't use kbd)-- may wish to consider filing against the

Do you have a disable/enable legacy usb and/or keyboard/mouse usb in
your bios? Does this make grub and/or the console work/not work?
Comment 7 rob versluis 2005-01-26 12:38:12 EST
I did try out a cable from PS/2 to USB, which came with the keyboard.
It works until X started: X took a very long time to start and it was
in a very bad quality displayed ->> not workable.

Tomorrow I can look for those USB support items in the bios. I will
report to you.
Comment 8 rob versluis 2005-01-27 01:29:18 EST
Dell Optiplex GX260
Bios A03 Service Tag: 1J58N0J

This is all I have found about USB:
- USB Emulation : OFF
- USB Controller: ON
- USB IRQ's     : 3,9*,10,11* 
  (IRQ's marked with * are also in use by other devices)

But I've nothing found about "keyboard" or "mouse" in the bios...
Comment 9 rob versluis 2005-02-28 05:08:48 EST
Kernel 2.6.10-1.766_FC3 did not bring a fix for this problem.
Comment 10 rob versluis 2005-02-28 05:37:19 EST
Upgrading the BIOS from A03 to A09 did not fix the problem.
Comment 11 Miloslav Trmač 2005-02-28 12:30:49 EST
Is the keyboard using the PS/2 connector?
If so, can you please boot with " init=/bin/sh" added to the kernel
command line (in grub, select the kernel, press 'a', type the string,
press Enter), and check whether the keyboard works?

If it is an USB keyboard, please try changing the "USB emulation"

Comment 12 rob versluis 2005-03-03 01:31:04 EST
The keyboard uses a PS/2 connector.

I can add the init line in grub, but when the shell is started it is
all over.
The only sign the keyboard give is flashing the Num-, Caps- and
ScrollLock if releasing the shift key.
Comment 13 Miloslav Trmač 2005-03-03 02:37:41 EST
Thanks. Apparently kbd has nothing to do with this, reassigning
to kernel.
Comment 14 rob versluis 2005-04-13 01:19:08 EDT
kernel-2.6.11-1.14_FC3 did not fix the problem.
Comment 15 Dave Jones 2005-07-15 13:39:10 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 16 rob versluis 2005-07-18 01:34:56 EDT
kernel-2.6.12-1.1372_FC3 did not fix the problem.
Comment 17 Brendan 2005-08-05 12:03:31 EDT
I am having the problem as well, but with a vanilla 2.6.12.x (.2 and .3 tested
with) on Mepis, so I do not think this is a Fedora problem. Reproduceable 80% of
the time. Sometimes it works, sometimes not. Console or X. Just dead.
Comment 18 rob versluis 2005-09-12 07:46:09 EDT
FC4 with kernel 2.6.12-1.1447_FC4 did not fix the problem.
Comment 19 Dave Jones 2005-09-30 02:08:08 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Comment 20 Dave Jones 2005-11-10 14:05:19 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 21 rob versluis 2005-12-02 04:34:15 EST
I tested the new kernel but the keyboard has the same problems as with older
kernels. For now I am using a PS/2 to USB converter to use the ms-naturalkeyboard.
Comment 22 Dave Jones 2005-12-06 18:35:32 EST

*** This bug has been marked as a duplicate of 142639 ***

Note You need to log in before you can comment on or make changes to this bug.