Bug 14359 - logrotate undocumented "sharedscripts" directive
Summary: logrotate undocumented "sharedscripts" directive
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-21 08:24 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-21 21:02:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-07-21 08:24:51 UTC
Installed samba and logrotate of beta4 on beta3.

Samba's logrotate script uses a new directive "sharedscripts" that is not 
documented in the logrotate man page.

Comment 1 Erik Troan 2000-07-21 12:38:49 UTC
It's in the man page for the new logrotate version 3.4

Comment 2 Bill Nottingham 2000-07-21 14:20:43 UTC
Whoops, I'll fix the samba requirement.

Comment 3 giulioo 2000-07-21 16:04:09 UTC
I do have logrotate version 3.4

[go@localhost go]$ rpm -ql logrotate
/etc/cron.daily/logrotate
/etc/logrotate.conf
/etc/logrotate.d
/usr/sbin/logrotate
/usr/share/man/man8/logrotate.8.gz
[go@localhost go]$ rpm -qf /usr/share/man/man8/logrotate.8.gz
logrotate-3.4-2
[go@localhost go]$ zgrep notifempty /usr/share/man/man8/logrotate.8.gz
Rotate the log file even if it is empty, overiding the \fBnotifempty\fR
\fBnotifempty\fR
[go@localhost go]$ zgrep sharedscripts /usr/share/man/man8/logrotate.8.gz
[go@localhost go]$ zgrep sharedscripts /etc/logrotate.d/samba
    sharedscripts
[go@localhost go]$


Comment 4 Erik Troan 2000-07-21 18:45:25 UTC
Do you have release 2 or 1 installed?

[root@porky linux]# rpm -q logrotate
logrotate-3.4-2
[root@porky linux]# rpm -V logrotate 
[root@porky linux]# rpm -ql logrotate
/etc/cron.daily/logrotate
/etc/logrotate.conf
/etc/logrotate.d
/usr/sbin/logrotate
/usr/share/man/man8/logrotate.8.gz
[root@porky linux]# zgrep sharedscripts /usr/share/man/man8/logrotate.8.gz
\fBnosharedscripts\fR
is rotated (this is the default, and overrides the \fBsharedscripts\fR
\fBsharedscripts\fR
if logs are actually rotated) (this overrides the \fbnosharedscripts\fR
[root@porky linux]# 


Comment 5 giulioo 2000-07-21 21:02:41 UTC
Sorry, I installed the rpm with --force --nodeps and the rpm db was updated, 
but the files were not. Maybe this is a bug somewhere else :-)

[root@localhost go]# /usr/sbin/logrotate -v
logrotate 3.3.2 - Copyright (C) 1995 - Red Hat Software
..

But see the following
(I used force because I was surprised to see a dependency in negative, 
something <= was needed instead of >=):
[root@localhost go]# rpm -q logrotate
logrotate-3.4-2
[root@localhost go]# zgrep sharedscript /usr/share/man/man8/logrotate.8.gz
[root@localhost go]# rpm -Uvh logrotate-3.4-2.i386.rpm
error: failed dependencies:
        rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed by logrotate-3.4-2
        rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by logrotate-3.4-2
[root@localhost go]# rpm -Uvh --nodeps logrotate-3.4-2.i386.rpm
package logrotate-3.4-2 is already installed
[root@localhost go]# rpm -Uvh --nodeps --force logrotate-3.4-2.i386.rpm
logrotate                   ##################################################
  ---        481 logrotate-3.4-2
  +++        485 logrotate-3.4-2
[root@localhost go]# zgrep sharedscript /usr/share/man/man8/logrotate.8.gz
[root@localhost go]# /usr/sbin/logrotate -v
logrotate 3.3.2 - Copyright (C) 1995 - Red Hat Software
...
#




Note You need to log in before you can comment on or make changes to this bug.