Bug 143676 - Kernel panic - not syncing: No init found.
Kernel panic - not syncing: No init found.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-23 14:42 EST by robert hobbs
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-03 09:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert hobbs 2004-12-23 14:42:03 EST
Description of problem:
When executing the redhat exec process crashes.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1.Logon to the z/VM 4.4 guest
2.Execute redhat exec
3.
  
Actual results:
Kernel panic - not syncing: No init found.

Expected results:
Start Redhat installation process

Additional info:
I will attach the VM log on the next screen
Comment 1 robert hobbs 2004-12-23 14:44:34 EST
Linux version 2.6.9-1.906_EL (bhcompile@spade.z900.redhat.com) (gcc 
version 3.4.
3 20041125 (Red Hat 3.4.3-6.EL4)) #1 SMP Mon Dec 13 00:04:02 EST 
2004           
We are running under VM (31 bit 
mode)                                           
This machine has an IEEE 
fpu                                                    
Built 1 
zonelists                                                             
  
Kernel command line: ROOT=/dev/ram0 ro IP=off DASD=200-
21f                      
                     
CHANDEV=qeth0,0x3004,0x3005,0x3006                         
                     HOSTNAME=ldal9020.fmr.com NETTYPE=eth 
IPADDR=10.73.64.30   
                     NETWORK=10.73.64.0 NETMASK=255.255.252.0 
BROADCAST=10.73.67
.255                 GATEWAY=10.73.64.1 DNS=155.200.144.15 
SEARCHDNS=fmr.com    
                     
QETHPARM=ADD_PARMS,0X10,0X3004,0X3006,PORTNAME:OSA01       
                     
vnc                                                        
PID hash table entries: 4096 (order: 12, 65536 
bytes)                           
Dentry cache hash table entries: 131072 (order: 7, 524288 
bytes)                
Inode-cache hash table entries: 65536 (order: 6, 262144 
bytes)                  
Memory: 508928k/524288k available (1869k kernel code, 0k reserved, 
617k data, 96
k 
init)                                                                 
        
Security Scaffold v1.0.0 
initialized                                            
SELinux:  
Initializing.                                                         
SELinux:  Starting in permissive 
mode                                           
There is already a security framework initialized, register_security 
failed.    
selinux_register_security:  Registering secondary module 
capability             
Capability LSM initialized as 
secondary                                         
Mount-cache hash table entries: 512 (order: 0, 4096 
bytes)                      
Detected 1 
CPU's                                                                
Boot cpu address  
0                                                             
cpu 0 phys_idx=0 vers=FF ident=06A20C machine=2084 
unused=8000                  
Brought up 1 
CPUs                                                               
checking if image is initramfs...it isn't (no cpio magic); looks like 
an initrd 
Freeing initrd memory: 5530k 
freed                                              
debug: Initialization 
complete                                               
NET: Registered protocol family 
16                                           
appldata info: mem-ops 
registered!                                           
appldata info: os-ops 
registered!                                            
appldata info: net_sum-ops 
registered!                                       
audit: initializing netlink socket 
(disabled)                                
audit(1103830983.470:0): 
initialized                                         
VFS: Disk quotas 
dquot_6.5.1                                                 
Dquot-cache hash table entries: 1024 (order 0, 4096 
bytes)                   
SELinux:  Registering netfilter 
hooks                                        
Initializing Cryptographic 
API                                               
ksign: Installing public key 
data                                            
Loading 
keyring                                                              
- Added public key 
1964C3FE1A7BDE32                                          
- User ID: Red Hat, Inc. (Kernel Module GPG 
key)                             
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 
blocksize       
md: md driver 0.90.0 MAX_MD_DEVS=256, 
MD_SB_DISKS=27                         
Channel measurement facility using extended format 
(autodetected)            
cpi: no system name 
specified                                                
NET: Registered protocol family 
2                                            
IP: routing cache hash table of 4096 buckets, 
32Kbytes                       
TCP: Hash tables configured (established 65536 bind 
65536)                   
Initializing IPsec netlink 
socket                                               
NET: Registered protocol family 
1                                               
NET: Registered protocol family 
17                                              
md: Autodetecting RAID 
arrays.                                                  
md: 
autorun ...                                                           
      
md: ... autorun 
DONE.                                                           
RAMDISK: Compressed image found at block 
0                                      
RAMDISK: incomplete write (-28 != 32768) 
16777216                               
VFS: Mounted root (ext2 filesystem) 
readonly.                                   
Freeing unused kernel memory: 96k 
freed                                         
attempt to access beyond end of 
device                                          
ram0: rw=0, want=32776, 
limit=32768                                             
EXT2-fs error (device ram0): ext2_get_inode: unable to read inode 
block - inode=
13345, 
block=16387                                                           
   
Kernel panic - not syncing: No init found.  Try passing init= option 
to kernel. 
HCPGIR450W CP entered; disabled wait PSW 000A0000 
800128EA                      
Comment 2 Jason Baron 2005-02-16 11:39:27 EST
Is this still an issue, with the latest beta? thanks.
Comment 3 robert hobbs 2005-03-03 09:48:08 EST
I successfully created a zLinux server using the Redhat EL4 GA distribution. 
This issue can be closed.

Note You need to log in before you can comment on or make changes to this bug.