Bug 143702 - can't mount CD after upgrade FC2 to FC3. Using HP nx9000 Laptop.
can't mount CD after upgrade FC2 to FC3. Using HP nx9000 Laptop.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-24 09:17 EST by yuval aviel
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuval aviel 2004-12-24 09:17:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
lcnpc18:nest # mount /dev/hdc /mnt/cdrom
/dev/hdc: Input/output error
mount: block device /dev/hdc is write-protected, mounting read-only
/dev/hdc: Input/output error
mount: /dev/hdc: can't read superblock
Never had this problem before (FC1 FC2).

Version-Release number of selected component (if applicable):
udev-039-10.FC3.6

How reproducible:
Always

Steps to Reproduce:
1. try to mount cdrom
2.
3.
    

Actual Results:  /dev/hdc: Input/output error

Additional info:

Looking into udev, I found that the script doesn't recognize the CDROM:
lcnpc18:nest # /etc/udev/scripts/check-cdrom.sh /dev/hdc ; echo $?
1


lcnpc18:nest # uname -a
Linux lcnpc18 2.6.9-1.681_FC3 #1 Thu Nov 18 15:10:10 EST 2004 i686
i686 i386 GNU/Linux
lcnpc18:nest # cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             hdc
drive speed:            24
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        0
Can write DVD-RAM:      0
Can read MRW:           0
Can write MRW:          0
Can write RAM:          0

From /var/log/messages:
Dec 20 11:26:48 lcnpc18 kernel: hdc: command error: status=0x51 {
DriveReady SeekComplete Error }
Dec 20 11:26:48 lcnpc18 kernel: hdc: command error: error=0x54
Dec 20 11:26:48 lcnpc18 kernel: ide: failed opcode was 100
Dec 20 11:26:48 lcnpc18 kernel: end_request: I/O error, dev hdc, sector 0
Dec 20 11:26:48 lcnpc18 kernel: Buffer I/O error on device hdc,
logical block 0

these lines repeat indefently ...
Comment 1 yuval aviel 2004-12-24 09:46:46 EST
disabling dma also didn't help:

lcnpc18:nest # hdparm -d0 /dev/hdc

/dev/hdc:
 setting using_dma to 0 (off)
 using_dma    =  0 (off)
lcnpc18:nest # mount /dev/hdc /mnt/cdrom
/dev/hdc: Input/output error
mount: block device /dev/hdc is write-protected, mounting read-only
/dev/hdc: Input/output error
mount: /dev/hdc: can't read superblock
lcnpc18:nest # 
Comment 2 Harald Hoyer 2005-01-03 03:48:17 EST
this is the kernel... not udev
you may try a newer kernel
Comment 3 yuval aviel 2005-01-04 03:29:06 EST
Upgrading to 2.6.10 didn't help. Same error messages.
Comment 4 Sharat 2005-01-16 01:31:45 EST
I see the same problem with my TEAC :
# cdrecord -checkdrive
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'TEAC    '
Identifikation : 'CD-W512EB       '
Revision       : '2.0B'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R

cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             hdc
drive speed:            32
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           0
Can write DVD-R:        0
Can write DVD-RAM:      0
Can read MRW:           0
Can write MRW:          0
Can write RAM:          0
Comment 5 Dave Jones 2005-07-15 15:15:37 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 yuval aviel 2005-07-18 12:43:30 EDT
The bug does not exist in FC4 (latest kernel-2.6.12). 
Thanks. 

Note You need to log in before you can comment on or make changes to this bug.