Bug 143714 - gamin - apparently something wrong with package provides/dependecies
gamin - apparently something wrong with package provides/dependecies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-24 18:46 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 05:42:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-12-24 18:46:43 EST
Description of problem:

With a freshly installed FC3 on x86_64 machine after 'yum update'
one sees the following:

Setting up Update Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B   
00:00     
Reading repository metadata in from local files
base      : ################################################## 2852/2852
updates-re: ################################################## 439/439
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gamin-devel.x86_64 0:0.0.17-1.FC3 set to be updated
---> Package gamin.x86_64 0:0.0.17-1.FC3 set to be updated
--> Running transaction check
--> Processing Dependency: libfam.so.0 for package: gnome-vfs2
--> Finished Dependency Resolution
Error: Missing Dependency: libfam.so.0 is needed by package gnome-vfs2

Closer examination indicates the 'gamin.i386' is not picked up,
even if available, and this is causing troubles.  Moreover, after

     yum install gamin.i386

attempt one sees "Nothing to do". :-(

As a workaround one can copy 'gamin-0.0.17-1.FC3.i386.rpm' to
an affected machine and after 'rpm -Uvh gamin-0.0.17-1.FC3.i386.rpm'
things are back to normal.  That means that 'yum update' works now
fine for all remaining packages.

This does not seem to affect machines which went through a number
of rounds of gradual updates but it messed up things on a new
installation.  Some "unfortunate cooperation" between gamin packaging
and yum?

Version-Release number of selected component (if applicable):
gamin-0.0.17-1.FC3.i386
Comment 1 Arenas Belon, Carlo Marcelo 2004-12-25 00:21:23 EST
gamin original (0.0.15) SPEC included a false provide with :

  Provides: libfam.so.0

and therefore the installed package for gnome-vfs2.i386 on fedora core
3 is indeed not operative.

this update fixes the bug but requires (as detailed before) that the
i386 package which provides that library which is non existant now as
shown below :

  # ldd /usr/lib/gnome-vfs-2.0/modules/libfile.so  | grep fam       
libfam.so.0 => not found

but seems to confuse yum into trying to find that the package which is
going to provide that dependency.

therefore this is an old gamin bug which was fixed and trigger a bug
on yum because of that.
Comment 2 Daniel Veillard 2005-03-14 05:42:40 EST
I think the dependancies are fixed, it was both an error in
gamin spec file provides and in gnome-vfs2 requires. As far as
I can tell this is fixed in Rawhide now.

Daniel 

Note You need to log in before you can comment on or make changes to this bug.