Bug 143719 - internal compiler error on spade-1.03 with
internal compiler error on spade-1.03 with
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
http://sourceforge.net/project/showfi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-25 00:02 EST by NOGUCHI Takuya
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.4.3-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-29 07:37:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The gziped preprocessed source (154.52 KB, application/x-gzip)
2004-12-25 00:44 EST, NOGUCHI Takuya
no flags Details

  None (edit)
Description NOGUCHI Takuya 2004-12-25 00:02:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
During compiling of spades, the following error happens because of 
commserver/test.cpp

Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1) Download spades source archieve:
$ wget
http://prdownloads.sourceforge.net/spades-sim/spades-1.03.tar.gz?download
2) Expand the source:
$ tar zxvf spades-1.03.tar.gz
3) Do configure and make:
$ cd spades-1.03; ./configure; make
4) Then the following error is occured:


Actual Results:  
if g++ -DHAVE_CONFIG_H -I. -I. -I.. 
-DSPADES_PKGLIB=\"/usr/local/lib/spades\"-I../shared -I../libltdl 
-DNO_ACTION_LOG  -g -O2 -MT test.o -MD -MP -MF ".deps/test.Tpo" \
  -c -o test.o `test -f 'test.cpp' || echo './'`test.cpp; \
then mv -f ".deps/test.Tpo" ".deps/test.Po"; \
else rm -f ".deps/test.Tpo"; exit 1; \
fi
test.cpp:581: internal compiler error: in output_die, at dwarf2out.c:6702
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccOFZrNB.out file, please attach
this to your bugreport.

Additional info:
Comment 1 NOGUCHI Takuya 2004-12-25 00:44:00 EST
Created attachment 109120 [details]
The gziped preprocessed source

spade-1.03/commserver/test.cpp
Comment 2 NOGUCHI Takuya 2004-12-25 00:59:44 EST
This bug is related to gcc Bug/16261
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=16261
Comment 4 Jakub Jelinek 2004-12-29 07:37:04 EST
Should be fixed in gcc-3.4.3-11 in rawhide.
Comment 5 Tim Powers 2005-06-09 06:57:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-257.html

Note You need to log in before you can comment on or make changes to this bug.