Bug 143735 - lack of ia32 packages in Compat Layer CD for ia64
Summary: lack of ia32 packages in Compat Layer CD for ia64
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-26 06:54 UTC by L3support
Modified: 2014-03-17 02:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-30 00:52:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description L3support 2004-12-26 06:54:57 UTC
Description of problem:
Some ia32 packages in compat layer CD fail to install owing to
dependencies error. But ia32 version of dependencies pacages aren't
included in the CD.


Version-Release number of selected component (if applicable):
Compat Layer CD ( in RHEL4 ia64 pre RC1 ) 

How reproducible:
always 

Steps to Reproduce:
1. mount compat layer CD
   # mount -o loop RHEL4-re1201.0-ia64-compat-layer-i386.iso /media/cdrom

2. install ia32 packages
   # cd /media/cdrom/RedHat/RPMS
   # rpm -ivh kdebase-3.3.1-4.i386 octave-2.1.57-7.i386
   error : Failed dependencies:
           /etc/X11/xdm/Xservers is needed by kdebase-3.3.1-4.i386
           /etc/X11/xdm/Xwilling is needed by kdebase-3.3.1-4.i386
           gnuplot is needed by octave-2.1.57-7.i386
       Suggested resolutions:
           gnuplot-4.0.0-4.ia64.rpm
           xorg-x11-xdm-6.8.1-12.ia64.rpm

   # ls gnuplot-4.0.0-4.ia64.rpm  xorg-x11-xdm-6.8.1-12.ia64.rpm
   ls: gnuplot-4.0.0-4.ia64.rpm: No such file or directory
   ls: xorg-x11-xdm-6.8.1-12.ia64.rpm: No such file or directory
  
Actual results:
   # rpm -ivh kdebase-3.3.1-4.i386 octave-2.1.57-7.i386
   error : Failed dependencies:
           /etc/X11/xdm/Xservers is needed by kdebase-3.3.1-4.i386
           /etc/X11/xdm/Xwilling is needed by kdebase-3.3.1-4.i386
           gnuplot is needed by octave-2.1.57-7.i386
       Suggested resolutions:
           gnuplot-4.0.0-4.ia64.rpm
           xorg-x11-xdm-6.8.1-12.ia64.rpm

   # ls gnuplot-4.0.0-4.ia64.rpm  xorg-x11-xdm-6.8.1-12.ia64.rpm
   ls: gnuplot-4.0.0-4.ia64.rpm: No such file or directory
   ls: xorg-x11-xdm-6.8.1-12.ia64.rpm: No such file or directory


Expected results:
succeed in installing all ia32 pacakges in Compat Layer CD regardless
of installed ia64 packages.

Additional info:

Comment 1 Jeff Johnson 2004-12-29 11:02:45 UTC
This seems to be a distribution rather than an rpm problem.

Comment 2 Bill Nottingham 2004-12-30 00:52:15 UTC
You may need ia64 packages to resolve dependencies.

Comment 3 L3support 2005-01-04 09:21:34 UTC
I think we need ia32 packages, but not ia64 packages. It seems to be
strange to install ia64 packages to resolve dependencies errors of
ia32 packages. Is it wrong?

Comment 4 Bill Nottingham 2005-01-04 18:05:08 UTC
No.

For example, it wants a gnuplot *binary* to call... this is provided
by the ia64 package.


Note You need to log in before you can comment on or make changes to this bug.