Bug 143748 - linux refuses to burn DVD+R DL media
linux refuses to burn DVD+R DL media
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-26 14:37 EST by tricia
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 12:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tricia 2004-12-26 14:37:48 EST
Description of problem:

Linux refuses to burn DVD DL media

Initially I tried with the following error...
=============================================

growisofs -Z /dev/cdrom -V X -dvd-compat /mnt/hda2/FilmName/
Executing 'mkisofs -V X /mnt/hda2/FileName/ | builtin_dd of=/dev/cdrom
obs=32k seek=0'
INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.
/dev/cdrom: splitting layers at 2007840 blocks
:-[ SEND DVD+R DOUBLE LAYER RECORDING INFORMATION failed with
SK=3h/ASC=02h/ACQ=00h]: Input/output error

I used mkisofs to generate an img
=================================

mkisofs -dvd-video -o /tmp/ATW.img

also I tried to bypass mkisofs as part of the growisofs command
===============================================================

growisofs -dvd-compat -overburn -Z /dev/cdrom=/tmp/ATW.img           
                                                                    
Executing 'builtin_dd if=/tmp/ATW.img of=/dev/cdrom obs=32k seek=0'
/dev/cdrom: splitting layers at 2035440 blocks
:-[ SEND DVD+R DOUBLE LAYER RECORDING INFORMATION failed with
SK=3h/ASC=02h/ACQ=00h]: Input/output error

I then tried to burn the media without success as follows .
===========================================================

growisofs -dvd-compat -overburn -Z /dev/cdrom=/tmp/ATW.img           
                                                                    
Executing 'builtin_dd if=/tmp/ATW.img of=/dev/cdrom obs=32k seek=0'
/dev/cdrom: splitting layers at 2035440 blocks
:-[ SEND DVD+R DOUBLE LAYER RECORDING INFORMATION failed with
SK=3h/ASC=02h/ACQ=00h]: Input/output error

Then I tried cdrecord directly using the image
==============================================

cdrecord -v gracetime=2 dev=/dev/cdrom speed=4 driveropts=burnfree
-overburn -raw96p /tmp/ATW.img
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 1 = CD-ROM
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3500AG'
Revision       : '2.16'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x002B
Profile: 0x002B (current)
Profile: 0x001B
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Drive buf size : 1769472 = 1728 KB
FIFO size      : 4194304 = 4096 KB
Encoding speed : 370x (27696 sectors/s) for libedc from Heiko Eißfeldt
Track 01: data  7950 MB
Total size:     9131 MB (904:37.98) = 4070849 sectors
Lout start:     9131 MB (904:39/74) = 4070849 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 281249 (62:31/74)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 281249 Blocks current: 281249 Blocks remaining: -3789600
cdrecord: WARNING: Data may not fit on current disk.
cdrecord: Notice: Most recorders cannot write CD's >= 90 minutes.
cdrecord: Notice: Use -ignsize option to allow >= 90 minutes.
cdrecord: Notice: Overburning active. Trying to write more than the
official disk capacity.
Speed set to 1411 KB/s
Starting to write CD/DVD at speed   8.0 in real RAW/RAW96P mode for
single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Performing OPC...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150 from ATIP
cdrecord: Illegal startsec (-150)
cdrecord: Could not write Lead-in.
Writing  time:    0.017s
BURN-Free was never needed.
cdrecord: fifo had 64 puts and 0 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

I tried cdrecord again with now raw option
==========================================

cdrecord -v gracetime=2 dev=/dev/cdrom speed=4 driveropts=burnfree
-overburn /tmp/ATW.img
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 1 = CD-ROM
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3500AG'
Revision       : '2.16'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x002B
Profile: 0x002B (current)
Profile: 0x001B
Profile: 0x001A
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Drive buf size : 1769472 = 1728 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  7950 MB
Total size:     9131 MB (904:38.01) = 4070851 sectors
Lout start:     9131 MB (904:40/01) = 4070851 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 281249 (62:31/74)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 281249 Blocks current: 281249 Blocks remaining: -3789602
cdrecord: WARNING: Data may not fit on current disk.
cdrecord: Notice: Most recorders cannot write CD's >= 90 minutes.
cdrecord: Notice: Use -ignsize option to allow >= 90 minutes.
cdrecord: Notice: Overburning active. Trying to write more than the
official disk capacity.
Speed set to 1411 KB/s
Starting to write CD/DVD at speed   8.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Performing OPC...
Starting new track at sector: 0
Track 01:    0 of 7950 MB written.cdrecord: Success. write_g1: scsi
sendcmd: no error
CDB:  2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 30 05 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x30 Qual 0x05 (cannot write medium - incompatible format)
Fru 0x0
Sense flags: Blk 0 (not valid)
resid: 63488
cmd finished after 0.000s timeout 40s
 
write track data: error after 0 bytes
cdrecord: A write error occured.
cdrecord: Please properly read the error message above.
Writing  time:    5.022s
Average write speed 999.0x.
Fixating...
cdrecord: Success. close track/session: scsi sendcmd: no error
CDB:  5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 30 05 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x30 Qual 0x05 (cannot write medium - incompatible format)
Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 480s
cmd finished after 0.000s timeout 480s
cdrecord: Cannot fixate disk.
Fixating time:    0.001s
BURN-Free was never needed.
cdrecord: fifo had 64 puts and 1 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.


Version-Release number of selected component (if applicable):

uname -a
Linux localhost.localdomain 2.6.6-1.435 #1 Mon Jun 14 09:09:07 EDT
2004 i686 athlon i386 GNU/Linux

cdrecord -version
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling

How reproducible:
#
see above

Steps to Reproduce:

e.g

cdrecord -v gracetime=2 dev=/dev/cdrom speed=4 driveropts=burnfree
-overburn -raw96p /tmp/ATW.img

  
Actual results:

see above

Expected results:

see above

Additional info:

dvdrecord -inq dev=/dev/hdb
============================

INFO: dvdrecord's functionality is now replaced by cdrecord
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/hdb'
devname: '/dev/hdb'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3500AG'
Revision       : '2.16'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
[root@localhost dvd]# clear
 
[root@localhost dvd]# dvdrecord -inq dev=/dev/hdb
INFO: dvdrecord's functionality is now replaced by cdrecord
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/hdb'


cdrecord dev=/dev/cdrom -prcap 
===============================

Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3500AG'
Revision       : '2.16'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
 
Drive capabilities, per MMC-3 page 2A:
 
  Does read CD-R media
  Does write CD-R media
  Does read CD-RW media
  Does write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does write DVD-R media
  Does not read DVD-RAM media
  Does not write DVD-RAM media
  Does support test writing
 
  Does read Mode 2 Form 1 blocks
  Does read Mode 2 Form 2 blocks
  Does read digital audio blocks
  Does restart non-streamed digital audio reads accurately
  Does support Buffer-Underrun-Free recording
  Does read multi-session CDs
  Does read fixed-packet CD media using Method 2
  Does not read CD bar code
  Does read R-W subcode information
  Does not return R-W subcode de-interleaved and error-corrected
  Does read raw P-W subcode data from lead in
  Does return CD media catalog number
  Does return CD ISRC information
  Does support C2 error pointers
  Does not deliver composite A/V data
 
  Does play audio CDs
  Number of volume control levels: 256
  Does support individual volume control setting for each channel
  Does support independent mute setting for each channel
  Does not support digital output on port 1
  Does not support digital output on port 2
 
  Loading mechanism type: tray
  Does support ejection of CD via START/STOP command
  Does not lock media on power up via prevent jumper
  Does allow media to be locked in the drive via PREVENT/ALLOW command
  Is not currently in a media-locked state
  Does not support changing side of disk
  Does not have load-empty-slot-in-changer feature
  Does not support Individual Disk Present feature
 
  Maximum read  speed:  8467 kB/s (CD  48x, DVD  6x)
  Current read  speed:  8467 kB/s (CD  48x, DVD  6x)
  Maximum write speed:  8467 kB/s (CD  48x, DVD  6x)
  Current write speed:  1411 kB/s (CD   8x, DVD  1x)
  Rotational control selected: CLV/PCAV
  Buffer size in KB: 2048
  Copy management revision supported: 1
  Number of supported write speeds: 6
  Write speed # 0:  8467 kB/s CLV/PCAV (CD  48x, DVD  6x)
  Write speed # 1:  7056 kB/s CLV/PCAV (CD  40x, DVD  5x)
  Write speed # 2:  5645 kB/s CLV/PCAV (CD  32x, DVD  4x)
  Write speed # 3:  4234 kB/s CLV/PCAV (CD  24x, DVD  3x)
  Write speed # 4:  2822 kB/s CLV/PCAV (CD  16x, DVD  2x)
  Write speed # 5:  1411 kB/s CLV/PCAV (CD   8x, DVD  1x)


devname: '/dev/hdb'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-3500AG'
Revision       : '2.16'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 keith adamson 2004-12-26 22:47:43 EST
Wish I had read this first before making a lot of coasters ... I have
same problem and same NEC drive
Comment 2 keith adamson 2004-12-26 22:55:11 EST
... BTW I'm running an up to date development tree (rawhide).
Comment 3 tricia 2005-01-13 15:58:03 EST
Is anyone ever going to bother thier arse looking at this ?
Comment 4 tricia 2005-01-13 16:03:27 EST
what I meant was if FC2 is no longer a priority I can log it against
FC3.  Apologies for the frustration.
Comment 5 Harald Hoyer 2005-01-14 04:28:35 EST
I cannot reproduce it, as I currently have no DL burner... 
Comment 6 tricia 2005-01-23 11:32:01 EST
What I have done in the past is run any requested tracing and dumped 
it on the bug trace, or ftp server if required.  There should be 
enough output on this bug report for a developer to determine the 
cause anyhow.  I cannot understand why someone developing DVD burner 
software cannot access a DVD burner, strange indeed. 
 
This is also a bug on FC3. 
Comment 7 Chuck Berg 2005-10-25 10:51:19 EDT
cdrecord (2.01.1-9.0.FC4.1) still can't (or refuses to) burn DVD+R DL disks.
Should this case apply to that or should a new one be opened? Should the
component for this be k3b when that's just a GUI layer? Is anyone at Redhat even
maintaining their modified cdrecord?
Comment 8 Harald Hoyer 2005-10-26 06:36:37 EDT
cdrecord cannot burn DVD+R DL disks... growisofs maybe.

Note You need to log in before you can comment on or make changes to this bug.