Bug 143753 - cannot load isdn
cannot load isdn
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: isdn4k-utils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-26 15:52 EST by A. Folger
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 12:57:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A. Folger 2004-12-26 15:52:20 EST
Description of problem:
When booting and/or when running the network device control dialog to
load a valid isdn device, the loading of the isdn modules fails.

Version-Release number of selected component (if applicable):
Problem appears since the release version of FC3, including when all
available updates until 22 Dec. are applied.

How reproducible:
Install FC3, install an isdn network interface (assuming you have a
supported isdn card) and start network device control gui or watch the
boot messages scroll by.

Steps to Reproduce:
1. Alternatively, run as root /etc/init.d/isdn restart
2.
3.
  
Actual results:
[FAILED] (is output from /etc/init.d/isdn restart)

# tail -n27 /var/log/messages
Dec 26 17:50:09 localhost kernel: CSLIP: code copyright 1989 Regents
of the University of California
Dec 26 17:50:09 localhost kernel: ISDN subsystem Rev:
1.1.2.3/1.1.2.3/1.1.2.2/1.1.2.3/1.1.2.2/1.1.2.2 loaded
Dec 26 17:50:09 localhost kernel: HiSax: Linux Driver for passive ISDN
cards
Dec 26 17:50:09 localhost kernel: HiSax: Version 3.5 (module)
Dec 26 17:50:09 localhost kernel: HiSax: Layer1 Revision 2.46.2.5
Dec 26 17:50:09 localhost kernel: HiSax: Layer2 Revision 2.30.2.4
Dec 26 17:50:09 localhost kernel: HiSax: TeiMgr Revision 2.20.2.3
Dec 26 17:50:09 localhost kernel: HiSax: Layer3 Revision 2.22.2.3
Dec 26 17:50:09 localhost kernel: HiSax: LinkLayer Revision 2.59.2.4
Dec 26 17:50:09 localhost kernel: HiSax: Card 1 Protocol EDSS1
Id=HiSax (0)
Dec 26 17:50:09 localhost kernel: HiSax: HFC-PCI driver Rev. 1.48.2.4
Dec 26 17:50:09 localhost kernel: PCI: Enabling device 0000:01:05.0
(0000 -> 0003)
Dec 26 17:50:09 localhost kernel: ACPI: PCI interrupt 0000:01:05.0[A]
-> GSI 17(level, low) -> IRQ 209
Dec 26 17:50:09 localhost kernel: HiSax: HFC-PCI card manufacturer:
CCD/Billion/Asuscom card name: 2BD0
Dec 26 17:50:09 localhost kernel: HFC-PCI: defined at mem 0x2a000 fifo
0x24308000(0x24308000) IRQ 209 HZ 1000
Dec 26 17:50:09 localhost kernel: HFC 2BDS0 PCI: IRQ 209 count 170
Dec 26 17:50:09 localhost kernel: HFC_PCI: resetting card
Dec 26 17:50:09 localhost kernel: HFC 2BDS0 PCI: IRQ 209 count 204
Dec 26 17:50:09 localhost kernel: HiSax: DSS1 Rev. 2.32.2.3
Dec 26 17:50:09 localhost kernel: HiSax: 2 channels added
Dec 26 17:50:09 localhost kernel: HiSax: MAX_WAITING_CALLS added
Dec 26 17:50:09 localhost isdn: Loading ISDN modules failed
Dec 26 17:50:09 localhost kernel: HiSax: release hfcpci at
ffffff000002a000
Dec 26 17:50:09 localhost kernel: HiSax module removed
Dec 26 17:50:09 localhost kernel: ISDN-subsystem unloaded


Expected results:
ISDN modules load and the network is up.

Additional info:
I am running FC3-test3-x86_64 on another partition, and everything
works well there.
I do not know whether the problem appears on other architectures, as I
didn't install a i386 partition (I already have 3 flavors of linux
running on this machine, and until this problem is worked out, I fear
that I won't be inclined to find extra space for a fourth partition).
Comment 1 A. Folger 2005-01-01 18:03:10 EST
This is weird. I manually upgraded my isdn-working FC3-test3 to FC3, 
so that I have now two partitions, one with FC3 from a fresh install, 
where isdn doesn't work, and one with FC3 that was (manually) 
upgraded from 2.92, and 2.91 before that, where isdn works just fine. 
I went through all the .rpmnew files and found nothing noteworthy. 
 
My sytem works now, but shouldn't we try to figure out what the bug 
is? 
Comment 2 A. Folger 2005-01-02 15:37:46 EST
Ahhh, I fixed it (I still have to figure out if this fix lasts between
reboots, but...) here it is:
[root@localhost afolger]# ln -s /dev/isdnctrl0 /dev/isdnctrl

For that matter, the /dev/cdrom symlink is also missing, breaking
`eject` untill the symlink is added.

By the way, I tried out the i386 version, and the problem is accross
all architectures, not just x86_64.
Comment 3 Ngo Than 2005-02-03 12:57:22 EST
The problem is the udev version in FC3 does not create the symlinks
/dev/cdrom and /dev/isdnctrl. Update of new udev will fix this problem.

Note You need to log in before you can comment on or make changes to this bug.