Bug 143768 - seven compile time problems
seven compile time problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openCryptoki (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 06:50 EST by David Binderman
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 06:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-12-27 06:50:15 EST
Description of problem:

I just tried to compile package openCryptoki-2.1.5-8 from 
Redhat Fedora development tree.

The compiler said

1.


apiutil.c(697): warning #1011: missing return statement at end of
non-void function "incr_sess_counts"

Suggest add return statement.

2.

apiutil.c(731): warning #1011: missing return statement at end of
non-void function "decr_sess_counts"
apiutil.c(1121): warning #1011: missing return statement at end of
non-void function "DL_Unload"
pkcsconf.c(678): warning #1011: missing return statement at end of
non-void function "echo"
pkcsconf.c(731): warning #1011: missing return statement at end of
non-void function "display_pkcs11_info"

Duplicates.

3.

pkcsconf.c(1023): warning #187: use of "=" where "==" may have been
intended

The source code is

      if (rc = CKR_PIN_INCORRECT) {

Legal, but deeply suspicous code. Suggest code review and possible rework.

4.

pkcsconf.c(1088): warning #187: use of "=" where "==" may have been
intended

Duplicate.

5.

../common/obj_mgr.c(2298): warning #1011: missing return statement at
end of non-void function "object_mgr_update_from_shm"

Suggest add return statement.


6.

soft_specific.c(399): warning #1011: missing return statement at end
of non-void function "token_specific_final"

Duplicate.

7.

no_odm.c(759): warning #267: the format string requires additional
arguments

The source code is

            fprintf(stderr, "\nReading Slot Info: %s: looking at %s,
stat64() returned %s (%d; %#x)", sinfo_struct.dll_location,
SysError(Err), Err, Err);

Five % specifiers, only four trailing parameters. Suggest code rework.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Binderman 2005-04-28 13:44:36 EDT
This bug still exists in version 2.1.5-9, in Fedora Core 4 test 1, dated
about 27 April 2005.
Comment 2 Phil Knirsch 2005-09-06 06:11:14 EDT
Fixed in latest development build.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.