Bug 143770 - keyboard layout switch back to US Layout
keyboard layout switch back to US Layout
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 07:04 EST by piccanto
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 13:37:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description piccanto 2004-12-27 07:04:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 7.50  [en]

Description of problem:
i installed FC3 with keyboard layout swiss german. After System reboot the keyboard 
layout switchs back  US Layout.  I must switch back manually to swiss german 
everytime i reboot the system.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.5-1

How reproducible:
Always

Steps to Reproduce:
1.switch to swissgerman layout
2.reboot system
3.try to mak a "z" or "y"
    

Actual Results:  keyboard layout back to US layout

Expected Results:  keyboard layout swissgerman

Additional info:
Comment 1 Paul Nasrat 2005-01-04 09:05:05 EST
Please attach 

cat /etc/sysconfig/keyboard and your xorg.conf as seperate,
uncompressed attachments please

Are you talking about console,X or both?
Comment 2 piccanto 2005-01-04 13:21:06 EST
Hello,
the problem is resolved.

before i installed FC3, i worked with FC2 and the home Directory
"/home/user" is on a own partition wich was configured and mounted in
FC3 unchanged. 
After installing FC3 the system had inform me on first boot that the
console layout not the same as in gnome, with a question wich layout
FC3  should use. i choose to use gnome layout, after that i take
notice about the problem buged. after 2 or 3 takes i detected that the
problem was in the home diretory of the user, after deleting this
directory "/home/user" and reinstalling a new user directory the
problem was taken.
have you an idear what the problem was ?? 
Comment 3 Paul Nasrat 2005-01-04 13:30:48 EST
Yes there are per-user preferences in gnome which can be set

Hat->Preferences->Keyboard which is seperate to
system-config-keyboard.  It's possible your FC2 user had a preference
set, if you had chosen to use the system layout it should have been
setup correctly.
Comment 4 piccanto 2005-01-04 13:35:42 EST
ok, thanks 
Comment 5 Paul Nasrat 2005-01-04 13:37:42 EST
Closing out.  

Note You need to log in before you can comment on or make changes to this bug.