Bug 143784 - latest up2date "unresolvable chain of dependencies" for the "bind" series of packages
latest up2date "unresolvable chain of dependencies" for the "bind" series of ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-27 14:57 EST by Kin Yip
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 15:04:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kin Yip 2004-12-27 14:57:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040805 Netscape/7.2

Description of problem:
Hi,

In the newest "up2date", there are 2 packages which
can be updates.  I attach the lines of error messages:

=================  Error messages =======================

Name                   Version        Rel     
----------------------------------------------------------
bind-libs              9.2.4          1_EL3             i386  
bind-utils             9.2.4          1_EL3             i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
bind  9.2.4-EL3_10                       requires libdns.so.11

============= End of error messages ==================


It seems that there should be an update for the "bind"
package at the same time as the packages "bind-libs" and 
"bind-utils".   Maybe, you guys forgot to include "bind" by 
mistake ?

My /etc/redhat-release looks like :

Red Hat Enterprise Linux WS release 3 (Taroon Update 4)

I'm runnig the kernel 2.4.21-27.EL on my Dell Optiplex 
GX 260 .

Kin


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just do "up2date -u" on the command line.


Actual Results:  One would obtain the error of "unresolvable chain of
dependencies" :

    
Name                       Version        Rel     
----------------------------------------------------------
bind-libs                   9.2.4          1_EL3             i386  
bind-utils                  9.2.4          1_EL3             i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
bind  9.2.4-EL3_10                       requires libdns.so.11


Expected Results:  Expect it to just finish updating.

Additional info:
Comment 1 Kin Yip 2005-01-11 14:17:39 EST
Hi,

I have found the reason.  It's because I'm updating towards
an OLD satellite server (for the purpose of RedHat up2date) 
in our Laboratory.  After I point to the new satellite 
server, this problem is resoled (the bind package is included
as well as bind-utils and bind-libs.

Sorry for this faase signal.

Kin

Note You need to log in before you can comment on or make changes to this bug.