Bug 143804 - tomcat5 start error: java.lang.NoClassDefFoundError: javax/management/MBeanRegistration
tomcat5 start error: java.lang.NoClassDefFoundError: javax/management/MBeanRe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Application Server Public Beta
Classification: Retired
Component: tomcat (Show other bugs)
1.0-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-28 08:27 EST by John Sopko
Modified: 2007-04-18 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 14:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sopko 2004-12-28 08:27:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
When trying to run tomcat5 get error:

java.lang.NoClassDefFoundError: javax/management/MBeanRegistration

See full error message below.

I subscribed to the RedHat Application Server Beta for (AS for i386)
channel an ran up2date. Then ran "up2date -u tomcat5" to get tomcat5
and all the packages it needs. This appeard to download and install all
neccessary packages. I ran up2date again and it did not find anything
that needed updating accept the kernel which I do not want to upgrade
now, ( need to compile afs etc).

I want to run tomcat5 in standalone mode, not through apache which
I believe is the default.

I tried setting JAVA_HOME to the RedHat supplied IBM java version and I
have loaded and tried Suns j2sdk1.4.2_06 java and get the same error
message. I ran both "/etc/init.d/tomcat start" and "/usr/bin/dtomcat5
start" and get the same problem accept the init.d/tomcat5 puts the
errors in the /var/log/tomcat/catalina.out log file.


[/etc/tomcat5] # rpm -q tomcat5
tomcat5-5.0.19-2jpp_3rh

[/etc/tomcat5] # rpm -q java-1.4.2-ibm
java-1.4.2-ibm-1.4.2.0-1jpp_13rh

I echo out the CLASSPATH in /usr/bin/dtomcat5 shown below:


Version-Release number of selected component (if applicable):
tomcat5-5.0.19-2jpp_3rh

How reproducible:
Always

Steps to Reproduce:
1. Run /etc/init.d/tomcat5 start 
2. or run /usr/bin/dtomcat5
3.
    

Actual Results:  [/etc/tomcat5] # /usr/bin/dtomcat5 run
Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JAVA_HOME:       /usr/lib/jvm/java-1.4.2-ibm-1.4.2.0/jre
CLASSPATH:
/usr/lib/jvm/java-1.4.2-ibm-1.4.2.0/jre/lib/tools.jar:/usr/share/tomcat5/bin/bootstrap.jar:/usr/share/tomcat5/bin/commons
-logging-api.jar
java.lang.NoClassDefFoundError: javax/management/MBeanRegistration
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:474)
        at java.net.URLClassLoader.access$500(URLClassLoader.java:108)
        at
java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:846)
        at java.security.AccessController.doPrivileged1(Native Method)
        at
java.security.AccessController.doPrivileged(AccessController.java:389)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:370)
        at
org.apache.catalina.loader.StandardClassLoader.findClass(StandardClassLoader.java:520)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:857)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:756)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:474)
        at java.net.URLClassLoader.access$500(URLClassLoader.java:108)
        at
java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:846)
        at java.security.AccessController.doPrivileged1(Native Method)
        at
java.security.AccessController.doPrivileged(AccessController.java:389)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:370)
        at
org.apache.catalina.loader.StandardClassLoader.findClass(StandardClassLoader.java:520)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:857)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:756)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
        at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:474)
        at java.net.URLClassLoader.access$500(URLClassLoader.java:108)
        at
java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:846)
        at java.security.AccessController.doPrivileged1(Native Method)
        at
java.security.AccessController.doPrivileged(AccessController.java:389)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:370)
        at
org.apache.catalina.loader.StandardClassLoader.findClass(StandardClassLoader.java:520)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:857)
        at
org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClassLoader.java:756)
        at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:215)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:375)

Expected Results:  No errors and a running tomcat5 server

Additional info:
Comment 1 Fernando Nasser 2005-01-05 14:43:09 EST
Hi,

This seems to be a beta version of RHAPS

We have released a version 1 of RHAPS in August 3, 2004!

http://www.redhat.com/software/rha/appserver/

As a RHEL subscriber you can subscribe to the appropriate channels to
get the proper packaged JVMs as well as an unsupported v1 release of
RHAPS at no cost.  But perhaps you can get the iso instead as you
should look at the Release Notes that is in the CD.  (all links from
the above URL)

Please follow the instructions to clean your system of old packages
before installing those as upgrades from the beta are not supported.

You should not have any problems to just say 'service tomcat start' or
to simply use redhat-config-services if you do that.

Thanks for your interest in trying RHAPS.

Regards,
Fernando
Comment 2 John Sopko 2005-01-06 07:36:18 EST
Hmmm, below are the channels that I have access to.
I used the Red Hat Application Server Beta (AS for i386).
I followed your link and it says "Red Hat Enterprise Linux subscribers
can download a free unsupported copy of Red Hat Application Server via
Red Hat Network", it just takes me to my account. Can you confirm the
proper Application Server channel is in place?

    *  Red Hat Enterprise Linux AS (v. 3 for x86)
          o Realm Linux AS3
          o Red Hat Application Server Beta (AS for i386)
          o Red Hat Developer Suite (for AS x86)
          o Red Hat Developer Suite (for AS x86) Beta
          o Red Hat Developer Suite 2.0 (AS for i386)
          o Red Hat Enterprise Linux AS (v. 3 for x86) Beta
          o Red Hat Enterprise Linux AS (v. 3 for x86) Extras
          o Red Hat Enterprise Linux AS (v. 3 for x86) Extras Beta
          o Red Hat Network Tools for RHEL 3 AS (i386)

I downloaded tomcat from the jakarta site and can run it without
a problem in a standalone directory.
Comment 3 Fernando Nasser 2005-01-07 13:55:18 EST
I've asked and I was told you should be subscribing to the RHAPS v1
channel:

"I usually do a 'up2date --show-channels' and if you have the RHAPS v1
channel, you should see:
rhel-3-as-i386-rhaps-1

If he logon to https://rhn.redhat.com/, he should be able to add that
channel to his machine."

You can also get the iso, which you should do anyway so you can get
the Release Notes that have some explanation on how to clean up your
system from older packages.  It has a graphical installer as well.

 
Comment 4 Fernando Nasser 2005-01-07 13:56:18 EST
I am copying Permaine, as she is the one helping with the RHN setup.
Comment 5 John Sopko 2005-01-07 14:16:54 EST
As I indicated in my previous comment, the rhaps-1 channel does not
show up on my available channels, only the rhaps-beta channel.
The easy iso's only allow me to download this ISO:

Red Hat Application Server Beta (AS for i386)

Here is what is subscribed to, there is no rhel-3-as-i386-rhaps-1
channel that I can subscribe to:

# up2date --show-channels
rhel-i386-as-3
rhel-i386-as-3-extras
rhel-3-as-i386-rhaps-beta

Comment 6 Permaine Cheung 2005-01-07 14:28:26 EST
As mentioned in the previous comment, your machine hasn't been
registered for that channel, you (or your sys admin) can do so by
logging on to https://rhn.redhat.com, then select your machine to add
the channel, click on 'Alter Channel Subscription', select Red Hat
Application Server (AS for i386), then click on 'Change Subscription'
to update that. After that's done, you should be able to see the RHAPS
v1 channel on your machine.

Note You need to log in before you can comment on or make changes to this bug.