Bug 143867 - Clumanager blocks signals in started Services
Clumanager blocks signals in started Services
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 149059 153070 161060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-30 08:54 EST by Uwe Müssel
Modified: 2009-04-16 16:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 16:21:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user script for service (194 bytes, text/plain)
2004-12-30 08:56 EST, Uwe Müssel
no flags Details
test_script (194 bytes, text/plain)
2004-12-30 08:56 EST, Uwe Müssel
no flags Details
Fixes problem (850 bytes, patch)
2005-01-03 11:36 EST, Lon Hohberger
no flags Details | Diff
Program from #149059 for testing (207 bytes, text/plain)
2005-02-25 12:38 EST, Lon Hohberger
no flags Details

  None (edit)
Description Uwe Müssel 2004-12-30 08:54:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When a custom defined service is started by the clustermanager via
script, a lot of signals including SIGUSR1 and SIGUSR2 are blocked.
Programms relying on these signals will not work correctly.

Version-Release number of selected component (if applicable):
clumanager-1.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. Install the screen package
2. create a cluster service unsing the attached test_script as user
script. This scripts simply starts a shell in a screen session
3. start the service 
4. attach to the session by entering "screen -r"
5. enter: trap ls 10
6. enter: kill -10 $$
    

Actual Results:  Nothing happens.

Expected Results:  The content of the current direcotry should appear
as it is if you start the screen session on the commansline by
entering "test_script start"

Additional info:
Comment 1 Uwe Müssel 2004-12-30 08:56:30 EST
Created attachment 109179 [details]
user script for service
Comment 2 Uwe Müssel 2004-12-30 08:56:40 EST
Created attachment 109180 [details]
test_script
Comment 3 Lon Hohberger 2005-01-03 11:36:38 EST
Created attachment 109260 [details]
Fixes problem

This patch changes clusvcmgrd to correctly unblock all signals prior to
starting the service script(s).
Comment 5 Lon Hohberger 2005-01-07 16:12:53 EST
Note: The following are not Red Hat errata; they are test
patches/packages.

Patch which fixes this and other bugzillas:

http://people.redhat.com/lhh/clumanager-1.2.23-0.4lhh.patch

Packages which fix this and several other current outstanding bugzillas:

http://people.redhat.com/lhh/clumanager-1.2.23-0.4lhh.i386.rpm
http://people.redhat.com/lhh/clumanager-1.2.23-0.4lhh.src.rpm
Comment 6 Lon Hohberger 2005-01-12 11:42:33 EST
1.2.23 packages have a bug which prevents IP addresses from properly
starting in some cases.

Consequently, I have fixed this problem and made a new test package:

http://people.redhat.com/lhh/clumanager-1.2.24-0.1.i386.rpm
http://people.redhat.com/lhh/clumanager-1.2.24-0.1.src.rpm
Comment 7 Lon Hohberger 2005-02-18 09:50:48 EST
*** Bug 149059 has been marked as a duplicate of this bug. ***
Comment 8 Lon Hohberger 2005-02-25 12:38:00 EST
Created attachment 111429 [details]
Program from #149059 for testing
Comment 10 Derek Anderson 2005-02-28 16:21:37 EST
Verified with the sigtest program.  It starts, and it fails over
properly.  Version clumanager-1.2.25-2.  Scheduled for release RHEL3-U5.
Comment 11 Lon Hohberger 2005-04-01 10:23:48 EST
*** Bug 153070 has been marked as a duplicate of this bug. ***
Comment 12 Jay Turner 2005-05-25 12:41:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-047.html
Comment 13 Jorge Izquierdo 2005-06-23 13:41:18 EDT
*** Bug 161060 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.