Bug 143876 - ghex fails build on x86_64
ghex fails build on x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marius L. Jøhndal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-30 11:25 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 18:48:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
suggested patch to allow ghex building on x86_64 when popt.i386 is installed (3.89 KB, patch)
2004-12-30 11:25 EST, Thorsten Leemhuis
no flags Details | Diff
second try to fix ghex2 on x86_64 -- uses make parm LIBTOOL= (1.55 KB, patch)
2005-01-09 10:08 EST, Thorsten Leemhuis
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2004-12-30 11:25:40 EST
Created attachment 109188 [details]
suggested patch to allow ghex building on x86_64 when popt.i386 is installed
Comment 1 Thorsten Leemhuis 2004-12-30 11:25:40 EST
ghex-2.8.0-3 did not build for preextras. Seems an insatlled opot package for
i386 is the troublemaker. Without it it builds fine, but if you use the
rpath-check from fedora-rpmdevtools the build also failes with:

 + /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
ERROR: file '/usr/bin/ghex2' contains a standard rpath '/usr/lib64' in [/usr/lib64]
Fehler: Bad exit status from /var/tmp/rpm-tmp.79246 (%install)

The attached patch fixes both problems. Discussion on the patch:
https://www.redhat.com/archives/fedora-extras-list/2004-December/msg00012.html
Comment 2 Marius L. Jøhndal 2005-01-05 06:32:51 EST
I've followed the discussion on fedora-extras [thanks for the Cc
anyway!], but unfortunately I don't have access to any system suitable
for package development at the moment, and, for reasons at least
partially beyond my control, I don't know when I will, so I'm not sure
when I can deal with this.

The no-scrollkeeper patch is essentially identical, right (i.e. except
for different line numbers)?
Comment 3 Thorsten Leemhuis 2005-01-05 12:08:37 EST
>but unfortunately I don't have access to any system suitable
>for package development at the moment, and, for reasons at least
>partially beyond my control, I don't know when I will, so I'm not
>sure when I can deal with this.

Ahh, okay. Good to know. Maybe I'll try to fix this package together
with Michael or someone else so we can at least build an x86_64
version. If you have problems with that: Just say and I'll stop!

>The no-scrollkeeper patch is essentially identical, right

Yes -- it was only neccessary due to the autoreconf stuff.
Comment 4 Marius L. Jøhndal 2005-01-06 03:13:11 EST
OK. You have my blessing to go ahead, and please coordinate it with
Michael.
Comment 5 Thorsten Leemhuis 2005-01-09 10:08:30 EST
Created attachment 109529 [details]
second try to fix ghex2 on x86_64 -- uses make parm LIBTOOL=

as discussed with mschwendt on fedora-extras-list; Build and execution tested
on x86_64 and i386
Comment 6 Michael Schwendt 2005-01-09 11:26:34 EST
Applied in CVS.
Comment 7 Michael Schwendt 2005-01-09 11:30:36 EST
[didn't mean to close this yet -- that was an accident ;)]
Comment 8 Michael Schwendt 2005-01-10 18:48:47 EST
Fixed in ghex-2.8.1-2.x86_64.rpm 

Note You need to log in before you can comment on or make changes to this bug.