Bug 143885 - http get request, and the questionmark char failure.
Summary: http get request, and the questionmark char failure.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-31 16:47 UTC by Jason Pyeron
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 11:38:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbug143885-1-0.src.rpm (1.98 KB, application/x-redhat-package-manager)
2004-12-31 17:07 UTC, Jason Pyeron
no flags Details
rpmbug143885-1-0.noarch.rpm (1.51 KB, application/x-redhat-package-manager)
2004-12-31 17:08 UTC, Jason Pyeron
no flags Details
disable glob for http (316 bytes, patch)
2005-02-08 20:59 UTC, Jason Pyeron
no flags Details | Diff

Description Jason Pyeron 2004-12-31 16:47:41 UTC
when fetching an rpm from a web server, like the default apache, the 
char '?' (question mark ASCII 0x3F) poses a serious obstacle for rpm.

[root@testserver1 rpm-4.2.3]# rpm --version
RPM version 4.2.3

Comment 1 Jason Pyeron 2004-12-31 17:06:16 UTC
similar to Bug 101731, but not the same.

Comment 2 Jason Pyeron 2004-12-31 17:07:56 UTC
Created attachment 109199 [details]
rpmbug143885-1-0.src.rpm

Comment 3 Jason Pyeron 2004-12-31 17:08:47 UTC
Created attachment 109200 [details]
rpmbug143885-1-0.noarch.rpm

Comment 4 Jason Pyeron 2004-12-31 17:11:42 UTC
[root@testserver redhat]# rpm -
ivv 'https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=109200&ac
tion=view'
error: File not found by glob: 
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=109200&action=
view
D: found 0 source and 0 binary packages
[root@testserver redhat]# curl -
I 'https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=109200&act
ion=view'
HTTP/1.1 200 OK
Date: Fri, 31 Dec 2004 17:10:59 GMT
Server: Apache/2.0.46 (Red Hat)
Content-Disposition: inline; filename=rpmbug143885-1-0.noarch.rpm
Content-Length: 1543
Content-Type: application/x-redhat-package-manager; 
name="rpmbug143885-1-0.noarch.rpm"

 

Comment 5 Jason Pyeron 2004-12-31 17:34:56 UTC
tried a workaround but ran into bug 143886.


Comment 6 Jeff Johnson 2005-02-07 20:05:23 UTC
Yep. The primitive url parser in rpm dates
back to 2000 or so, and there has been absolutely no need
to handle options in http: URL's

Adding RFE: to summary ...

Comment 7 Suzanne Hillman 2005-02-08 19:29:06 UTC
Internal RFE bug #147523 entered; will be considered for future releases.

Comment 8 Jason Pyeron 2005-02-08 20:25:24 UTC
this is a BUG not an RFE

http[s] urls are allowed to have ? chars in them.

I am currently working on a patch.

We cannot use rpm to install updates unless it can fetch them from 
the webserver.

i.e.

http://server/update?machine=1234&prod=5678



Comment 9 Jason Pyeron 2005-02-08 20:59:35 UTC
Created attachment 110821 [details]
disable glob for http

Comment 10 Jason Pyeron 2005-02-08 21:25:16 UTC
We have tested this, it works, but we do not have a formal test suite 
for RPM. Can someone please review and check this in ASAP.

On the next up2date push of rpm, we will loose our changes to rpm (or 
worse)




Comment 11 Suzanne Hillman 2005-02-09 20:47:15 UTC
Is there a particular reason that you are using a web server rather
than RHN or a satellite server?

Comment 12 Jason Pyeron 2005-02-09 20:55:51 UTC
yes, client corporate requirements.

Comment 13 Jason Pyeron 2005-02-12 14:49:48 UTC
when using curl to work around this issue, you can encounter
bug 145367 of curl in rhel.


this needs to checked in asap.

Comment 14 Jason Pyeron 2006-02-13 04:08:44 UTC
I do not see why the severity has been lowered?

If the severity has been lowered as part of a triage effort, I will raise it 
back to high in the days following if there is no activity.

Comment 15 Jason Pyeron 2006-02-13 04:10:44 UTC
It has been a year, with a patch...

Comment 16 Jeff Johnson 2006-02-13 12:08:38 UTC
Disabling a glob ain't exactly viable, handling the '?' as a URI option character is what needs to be done.

Comment 17 Jeff Johnson 2006-02-13 12:11:46 UTC
The severity has been lowered because you are not the only user, nor is this he only bug.
There is nothing in this report that warrants marking severity HIGH imho.

But feel free to do whatever you wish.

Comment 18 Jeff Johnson 2007-01-04 04:44:27 UTC
Fixed in rpm CVS, will be in rpm-4.4.8-0.9 when built.

UPSTREAM

Comment 19 Panu Matilainen 2007-10-11 11:38:31 UTC
Not going to be fixed for RHEL 3 at this point in it's lifecycle, sorry. The
curl bug has been fixed quite some time ago so at least it can be worked around
reasonably easily.


Note You need to log in before you can comment on or make changes to this bug.