Bug 143895 - with ACPI=ON USB mouse not detected.
with ACPI=ON USB mouse not detected.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-31 14:49 EST by Gene Czarcinski
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-09 15:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (15.10 KB, text/plain)
2005-01-07 17:54 EST, Gene Czarcinski
no flags Details
dmesg with 2.6.10-1.727_FC3 kernel and no_handshake=1 specified (14.98 KB, text/plain)
2005-01-08 10:49 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2004-12-31 14:49:48 EST
Description of problem:
The system is a Compaq R3000z (Athlon64) with multi-boot systems
installed.  WinXP is installed in hda1 (squoze down), a minimal FC3
i386 in hda3, swap as hda2, FC3 i386 everything install in hda5 and
FC3 x86_64 everything install in hda6.  The problem occurs with both
i386 and x86_64 systems.  

Booting with ACPI=ON (actually nothing specified), my USB mouse
(assumed 1.1) is not detected (although the synaptic touchpad is
detected as a generic PS2 two-button input device).

Booting with ACPI=OFF, my USB mouse is not detected (but the touchpad
is not).

Searching both bugzilla.redhat.com and bugzilla.kernel.org show some
reports of possible conflict between ACPI and USB support.

I am somewhat dependent on the "standard" FC3 kernels and thus
bugzilla.kernel.org will ignore/reject any of my reports.

This system is currently in a test mode so I am able to try various
things since this may be somewhat unique to the R3000z.  I am also
willing to build kernels with "special" configuration stuff set.

Version-Release number of selected component (if applicable):
FC3 with all "current" updates applied including kernel 2.6.9-1.698_FC3

This report may also be related to:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143893
and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143894
Comment 1 Gene Czarcinski 2005-01-02 13:28:13 EST
BTW, running with ACPI=OFF is NOT a real solution since with ACPI
disabled, the cpuspeed is not variable (i.e., it runs in slow mode).

Also, if I do run with acpi=off and add i8042.nomux then both of the
input pointers (USB mouse and synaptics touchpad work BUT the kerboard
does not work.
Comment 2 Gene Czarcinski 2005-01-07 17:54:26 EST
Created attachment 109504 [details]
dmesg

Updated to kernel 2.6.10-1.727_FC3 ... no difference

Note the following from dmesg:

ehci_hcd 0000:00:02.2: EHCI Host Controller
PCI: Setting latency timer of device 0000:00:02.2 to 64
ehci_hcd 0000:00:02.2: irq 10, pci mem 0xe0004000
ehci_hcd 0000:00:02.2: new USB bus registered, assigned bus number 1
PCI: cache line size of 64 is not supported by device 0000:00:02.2
ehci_hcd 0000:00:02.2: USB 2.0 initialized, EHCI 1.00, driver 26 Oct 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [LUS0] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 11 (level, low) -> IRQ 11
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: USB HC TakeOver failed!
ohci_hcd 0000:00:02.0: can't reset
ohci_hcd 0000:00:02.0: init 0000:00:02.0 fail, -16
ohci_hcd: probe of 0000:00:02.0 failed with error -16
Comment 3 Gene Czarcinski 2005-01-07 18:59:46 EST
Hoho ... I found this http://bugzilla.kernel.org/show_bug.cgi?id=3301
which has the same error message I am getting.

The problems are:  

1. I do not understand the patch (which probably will not fit 2.6.10
anyway) and

2. The comment with the close is:

"closing; the module parameter should address similar issues 
in the future."

and I have no idea what this means.
Comment 4 Alan Cox 2005-01-08 10:17:02 EST
In 2.6.10 series kernels the OHCI driver supports the option

no_handshake = 1

to rudely take over the OHCI hub in question from the BIOS instead of
being polite and failing as it does now.
Comment 5 Gene Czarcinski 2005-01-08 10:49:39 EST
Created attachment 109512 [details]
dmesg with 2.6.10-1.727_FC3 kernel and no_handshake=1 specified

Thanks Alan ... I was in the middle of fixing my typos in /etc/modprobe.conf
when I saw your update.  Unfortunately, the patch and specifying:

alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
options usb-controller1 no_handshake=1

does not appear to work since it still does not work and I get:

ehci_hcd 0000:00:02.2: USB 2.0 initialized, EHCI 1.00, driver 26 Oct 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [LUS0] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 11 (level, low) -> IRQ 11
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: USB HC TakeOver failed!
ohci_hcd 0000:00:02.0: can't reset
ohci_hcd 0000:00:02.0: init 0000:00:02.0 fail, -16
ohci_hcd: probe of 0000:00:02.0 failed with error -16
ACPI: PCI Interrupt Link [LUS1] enabled at IRQ 10
ACPI: PCI interrupt 0000:00:02.1[B] -> GSI 10 (level, low) -> IRQ 10
ohci_hcd 0000:00:02.1: OHCI Host Controller
ohci_hcd 0000:00:02.1: USB HC TakeOver failed!
ohci_hcd 0000:00:02.1: can't reset
ohci_hcd 0000:00:02.1: init 0000:00:02.1 fail, -16
ohci_hcd: probe of 0000:00:02.1 failed with error -16
Comment 6 Gene Czarcinski 2005-01-09 15:24:42 EST
OK, I am closing this as "NOTABUG" since I have been able to "fix" the
problem by applying the latest BIOS upgrade from HP -- F33 (SP29481.EXE).

 While there might be something wrong in the kernel, both touchpad and
the USB mouse are now working with the BIOS update.
Comment 7 Eddie Sturgis 2005-01-13 09:58:41 EST
The proper implementation of the no_handshake option in /etc/modprobe.conf for
the 2.6.10 kernel is

alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
options ohci-hcd no_handshake=1

This solved my USB mouse problem without the BIOS upgrade.
Comment 8 Gene Czarcinski 2005-01-13 20:22:49 EST
Unfortunately, doing no_handshake=1 did not fix anything for me
although up2date the BIOS did.
Comment 9 Eddie Sturgis 2005-01-14 09:37:10 EST
I should have been more specific in my response.  When I specified 
'options usb-controller1 no_handshake=1'
in /etc/modprobe.conf, my mouse still did not work.  When I changed the line to
'options ohci-hcd no_handshake=1'
then the mouse worked fine.

Note You need to log in before you can comment on or make changes to this bug.