Bug 143914 - x86_64 FC2 -> FC3 update fails: change of arch
x86_64 FC2 -> FC3 update fails: change of arch
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 04:59 EST by Richard Hill
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-13 23:16:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hill 2005-01-01 04:59:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
I have FC2 (X86_64) and I'm trying to upgrade to FC3 (X86_64) and
always get the error -

"The arch of the release of Fedora Core you are upgrading to appears
to be i386 which does not match your previously installed arch of X86_64."

The FC3 DVD image is definately x86_64.






Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. FC2 -> FC3 update on x86_64
2.
3.
    

Additional info:

rpm -q --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}" initscripts
initscripts-7.53-1.i386initscripts-7.53-1.x86_64

If I ignore the error, anaconda segfaults during "Preparing to
install" (but this happens during a full install also - seperate bug
reported)

cat .discinfo
1099519842.860000
Fedora Core 3
x86_64
1,2,3,4
Fedora/base
Fedora/RPMS
Fedora/pixmaps


extract from update.log
Upgrade Dependency: Needs (('licq', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-kde', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-qt', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-text', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-gnome', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-kde', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-qt', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2.2)(64bit)', None), 0, None, 0),
automatically added.
Upgrade Dependency: Needs (('licq-text', '1.2.7', '3'),
('libstdc++.so.5(GLIBCPP_3.2.2)(64bit)', None), 0, None, 0),
automatically added.
Comment 1 Paul Nasrat 2005-01-04 11:12:27 EST
Out of curiosity what updater do you use (yum/up2date)? Can you attach the
appropriate configuration (/etc/yum.conf, /etc/sysconfig/rhn/sources).

I can see why the failure is occuring but I'm curious as to how you ended up
with an i386 initscripts, it's possibly you're pointing at the all arch header
list rather than the per-arch subtree.
Comment 2 Richard Hill 2005-01-04 12:02:34 EST
I'm doing an upgrade from the install DVD, so I presume yum doesn't come
into it? FC2 was also an full installation from the FC2 DVD.

Maybe it's getting confused because I also have an FC3 (32 bit) on another 
disk ?  (But I did select the correct partition when asked which partition I'd 
like to upgrade)
Comment 3 Paul Nasrat 2005-01-04 13:26:51 EST
However you state when booted into FC2 x86_64 you have:

rpm -q --qf "[%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n]" initscripts
initscripts-7.53-1.i386
initscripts-7.53-1.x86_64

Can you confirm that my understanding is correct.

The tree should just have x86_64

http://download.fedora.redhat.com/pub/fedora/linux/core/2/x86_64/os/Fedora/RPMS/

I've checked the DVD iso image - it only has the x86_64 version on

I want to confirm that the rpmdb of your x86_64 has that and why.  I pretty much
know what to fix anaconda side, but I want to understand the path you've taken
to get to this.  Was this an upgrade from fc1?  
Comment 4 Richard Hill 2005-01-05 08:39:57 EST
I checked again.  Yes both versions of initscripts are installed.
I cannot say how.  I installed FC2 from DVD.  I didn't do any 
updates.  Now I'm trying to install FC3 from DVD.  FC2 was the
first install on this system.  FC1 was never there.

I do have FC3 (32 bit) on another partition, but this was never on 
the partition where X86_64 is.

Might be better to just do a full FC3 install ?
Comment 5 Paul Nasrat 2005-02-13 23:16:47 EST
Sorry for the delay - rpm -e initscripts.i386 --justdb should enable you to upgrade.

I'm still can't see how you got both initscripts installed though.  I'm going to
close this, but please re-open if you can reproduce getting both initscripts
installed.

Note You need to log in before you can comment on or make changes to this bug.