Bug 143918 - kernel panic
kernel panic
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Viro
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 06:03 EST by NiCK
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport result (223.24 KB, application/octet-stream)
2005-01-03 21:09 EST, NiCK
no flags Details

  None (edit)
Description NiCK 2005-01-01 06:03:12 EST
*pte=7273752f
Oops = 0000
parport_pl lp parport autofs4 audit b44 floppy sg microcode
keybdev mousedev hid input ehei-hcd usb-uhci ubcore ext3
jbd aic7xxx diskdumplib sd-mod scsi-mod
cpu : 0
EIP : 0060:[<04245c8b>] Not tainted
EFLAGS : 00010206
EIP is at Using_versions [] 0x4245c8a (2.4.21-20.ELsmp/i686)
eax : f8884720 ebx : c39f8d00  ecx : 04245c8b edx : c03a7ebc
esi : de8ca689 edi : ffffffed ebp : c3aaedc0 esp : db929f54
ds : 0068 es : 0068 53 : 0068
process updatedb (pid=6642,stackpage=db929000)
stack : co162490 de8ca680 c39f8d00 00018800 f6366000 08906e0 bfffca48 
c0162378
de8cda80 c3a9edc0 00018800 db929f84 de8cda80 c3a9edc0 f6396000 
c3936720
00000005 00000003 00000001 089906e0 00000005 c0162783 f6396000 
00018800
Call Trace: [<c0162490>] dentry_open [kernel] 0x110(0xdb929f54)
[<c0162378>] filp_open  [kernel] 0x68 (0xdb929f70)
[<c0162783>] sys_open [kernel] 0x53(0xdb929fa8)
Code : Bad EIP Value
Kernel panic : Fatal exception
Comment 1 Suzanne Hillman 2005-01-03 13:40:52 EST
What was going on that caused this? 

What is the hardware of machine in question, and is the problem reproducible?
Comment 2 NiCK 2005-01-03 21:09:26 EST
Created attachment 109307 [details]
sysreport result
Comment 3 NiCK 2005-01-03 21:14:33 EST
hi,Suzanne Hillman.
Comment #2 is sysreport result.
The problem occurs once a day or 2 days or 3 days. 

Comment 4 Larry Woodman 2005-01-03 21:47:53 EST
This crash appears to be caused by a corrupt fops struct in dentry_open().

dentry_open()------------------------

f->f_op = fops_get(inode->i_fop);        
...
if (f->f_op && f->f_op->open) {
    error = f->f_op->open(inode,f);
...
-------------------------------------


Can you reproduce this with the RHEL3-U4 kernel?  We did fix corruption
problems in that kernel.
Comment 5 Alexander Viro 2005-01-05 12:05:00 EST
7273752f => "/vsr".  Not something one would expect to find in page table...
Care to post other oopsen of the same sort?
Comment 6 RHEL Product and Program Management 2007-10-19 15:10:14 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.