Bug 143919 - netconf.py crash with some strings in the kernel relase
netconf.py crash with some strings in the kernel relase
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 06:37 EST by Yves L'ECUYER
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 07:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yves L'ECUYER 2005-01-01 06:37:09 EST
Description of problem:launching neat crash


Version-Release number of selected component (if applicable):

1.3.16
How reproducible:
each time  the command is launched

Steps to Reproduce:
1.
I beleve that it's related to the presence of two characters '-' in
the kernel release, because with a release name like 2.6.9 or
2.6.9-foo.8, there is no problems

2.
3.
  
Actual results:
see Additional info as reported by the bug windows opened by
netconf.py itself

Expected results:
a working script !

Additional info:
-------------------------------------------------------------
Component: system-config-network
Version: 1.3.16
Summary: TB1915175a NC_functions.py:55:kernel_version:ValueError:
unpack list of wrong size
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 183, in ?
    from netconfpkg import NC_functions
  File
"/var/tmp/system-config-network-1.3.16-root/usr/share/system-config-network/netconfpkg/__init__.py",
line 61, in ?
  File "<string>", line 1, in ?
  File
"/var/tmp/system-config-network-1.3.16-root/usr/share/system-config-network/netconfpkg/Control.py",
line 28, in ?
  File
"/var/tmp/system-config-network-1.3.16-root/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 79, in ?
  File
"/var/tmp/system-config-network-1.3.16-root/usr/share/system-config-network/netconfpkg/NC_functions.py",
line 55, in kernel_version
ValueError: unpack list of wrong size

Local variables in innermost frame:
release: 2.6.9-32bit-2
sysname: Linux
machine: i686
version: #6 Sat Nov 13 12:59:29 CET 2004
nodename: ismf33

Note You need to log in before you can comment on or make changes to this bug.