Bug 143921 - 2 * local variable used before set
2 * local variable used before set
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 07:02 EST by David Binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 10:19:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-01-01 07:02:38 EST
Description of problem:

I just tried to compile package xscreensaver-4.18-14 from 
Redhat Fedora development tree.

The compiler said

1.

./xscreensaver-config-tool.c(903): remark #592: variable "hack" is
used before its value is set

The source code is

          screen_hack_free (hack);

It seems that hack is not initialised since its declaration.  Suggest init
hack before first use.

2.

./xscreensaver-config-tool.c(972): remark #592: variable "hack" is
used before its value is set

Duplicate.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ray Strode [halfline] 2005-01-21 10:19:41 EST
Hi,

The xscreensaver-config-tool made a brief appearance in rawhide to
handle the "split xscreensaver up" problem, but another approach was
taken after some discussion with the author of xscreensaver.

Note You need to log in before you can comment on or make changes to this bug.