Bug 143934 - ifconfig reports errors RX-ERR e1000 500mb file xfer
ifconfig reports errors RX-ERR e1000 500mb file xfer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-tools (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 16:53 EST by Mike Kinney
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 14:16:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Kinney 2005-01-01 16:53:46 EST
Description of problem:
ifconfig reports errors RX-ERR when transfering large files (500mb)
from Fedora Core 3 (FC3) gigabit client to RHEL 3 update 4 gigabit
server. Both have e1000 intel gigabit nics.

I suspect that the gigabit transfers are overwhelming the nic causing
errors. The RHEL server has IDE drives and can copy the file from /tmp
to /tmp in about 23 seconds. scp'ing the file goes in about 28
seconds. There are gigabit switches between the computers. 

Version-Release number of selected component (if applicable):
net-tools-1.60-20E.1 (RHEL)
net-tools-1.60-37 (FC3)

How reproducible:
Setup one linux client and one RHEL server with gigabit nics.

Steps to Reproduce:
1. client: dd if=/dev/zero of=/tmp/mike bs=1M count=500
2. ifconfig | grep "RX packets"
3. client: scp /tmp/mike servername:/tmp/
4. ifconfig | grep "RX packets"

Actual results:
A) Before scp'ing, ifconfig reports:
[root@dragon tmp]# ifconfig | grep "RX packets"
          RX packets:29328142 errors:37155 dropped:0 overruns:0
frame:37155
          RX packets:585280 errors:0 dropped:0 overruns:0 frame:0

B) After scp'ing, ifconfig reports:
[root@dragon tmp]# ifconfig | grep "RX packets"
          RX packets:29787794 errors:37822 dropped:0 overruns:0
frame:37822
          RX packets:587049 errors:0 dropped:0 overruns:0 frame:0

Expected results:
A) 0 errors (maybe???) If they're not dropped nor overruns, what kinds
of errors are they?
B) /var/log/message messages as to what might be causing errors
(maybe???) There might be a debug -vv or -D9 switch, but I don't know
where/how to enable it.
C) Are these *real* errors? Is there a way to classify them? Report
more detail?
D) If RX errors on server, then why would we not see TX errors on FC3
client?

Additional info:
dragon is RHEL server with IDE drive (on /tmp partition) Small network
of 20-30 computers/printers. Not a lot of traffic during testing.

A) Copying a file from/to same hard drive takes 23 seconds.
[root@dragon tmp]# ls -al mike
-rw-r--r--    1 kinneym  kinneym  524288000 Dec 30 14:04 mike
[root@dragon tmp]# time cp mike mike2

real    0m23.718s
user    0m0.080s
sys     0m5.020s
[root@dragon tmp]#

B) scp'ing file from FC3 client takes 28 seconds.
[root@aguila tmp]# scp -P 901 mike 192.168.123.139:/tmp/
root@192.168.123.139's password:
mike                                          100%  500MB  17.9MB/s  
00:28

C) [root@dragon tmp]# lsmod | grep e100
e1000                  77884   1
e100                   60048   0  (unused)

D) [root@dragon tmp]# uname -a
Linux dragon.XXXX 2.4.21-27.0.1.ELsmp #1 SMP Mon Dec 20 18:47:45 EST
2004 i686 i686 i386 GNU/Linux

E) client shows no TX (nor RX) errors. Another FC3 client with a
different NIC (DLINK gigabit nic) shows no TX (nor RX) errors.

F) trasferring 500mb file from two clients at same time results in
expected combined thruput:
client1: 
mike                                          100%  500MB  11.1MB/s  
00:45
client2:
mike                                          100%  500MB  11.6MB/s  
00:43
combined: 22.7MB/sec... uh, okay... not 100% scientific, but at least
performance did not degrade. ;-) When I xferred 5gb files at same time
from two different clients sustained combined thruput was about 28mb/sec.

G) after all of these tests, ifconfig reports:
          RX packets:38629800 errors:51053 dropped:0 overruns:0
frame:51053

Let me know if there is more info that I can provide.
Comment 1 Jesse Brandeburg 2005-01-25 13:52:53 EST
Please post results of ethtool -S ethX where X is [0..9]
also useful would be before and after on netstat -s

rx_errors unfortunately has rnbc (receive no buffers count) included
which may not actually indicate a dropped packet, just one which the
fifo on the adapter may have had to buffer while the OS provided more
receive data areas.

RNBC is an indication that the adapter may need more RxDescriptors
(see the e1000 README)
Comment 2 Mike Kinney 2005-01-26 14:24:22 EST
I have since upgraded RHEL *AND* FC3 clients. 

(dragon) RHEL client is:  2.4.21-27.0.1.ELsmp #1 SMP Mon Dec 20
18:47:45 EST 2004 i686 i686 i386 GNU/Linux

FC3 client is: 2.6.10-1.741_FC3smp #1 SMP 

The net-tools is the same version: net-tools-1.60-20E.1

Kernel modules e100 and e1000 look to be the same size:
[root@dragon backups]# lsmod | grep e100
e1000                  77884   1
e100                   60048   0  (unused)

I transferred about 6gb and saw NO ERRORS. I *assume* the kernel
changes made a difference. Maybe?!?! I also re-did the test steps
above and still no errors. Is it possible for the kernel(s) to have
fixed/solved the problem?!?

Okay by me to close this. 

For what it's worth... here's my re-test data:
[root@dragon backups]# ethtool -S eth0
NIC statistics:
     rx_packets: 0
     tx_packets: 0
     rx_bytes: 0
     tx_bytes: 0
     rx_errors: 0
     tx_errors: 0
     rx_dropped: 0
     tx_dropped: 0
     multicast: 0
     collisions: 0
     rx_length_errors: 0
     rx_over_errors: 0
     rx_crc_errors: 0
     rx_frame_errors: 0
     rx_fifo_errors: 0
     rx_missed_errors: 0
     tx_aborted_errors: 0
     tx_carrier_errors: 0
     tx_fifo_errors: 0
     tx_heartbeat_errors: 0
     tx_window_errors: 0
     tx_late_collision_errors: 0
     tx_deferred: 0
     tx_single_collisions: 0
     tx_multi_collisions: 0
     rx_collision_detected_errors: 0
     tx_flow_control_pause: 0
     rx_flow_control_pause: 0
     rx_flow_control_unsupported: 0
     tx_tco_packets: 0
     rx_tco_packets: 0
[root@dragon backups]# netstat -s
Ip:
    8429445 total packets received
    0 forwarded
    0 incoming packets discarded
    8429226 incoming packets delivered
    4378678 requests sent out
Icmp:
    8 ICMP messages received
    2 input ICMP message failed.
    ICMP input histogram:
        destination unreachable: 5
        echo requests: 3
    8 ICMP messages sent
    0 ICMP messages failed
    ICMP output histogram:
        destination unreachable: 5
        echo replies: 3
Tcp:
    167 active connections openings
    351 passive connection openings
    2 failed connection attempts
    7 connection resets received
    4 connections established
    8425103 segments received
    4377655 segments send out
    44 segments retransmited
    0 bad segments received.
    110 resets sent
Udp:
    4157 packets received
    0 packets to unknown port received.
    0 packet receive errors
    1015 packets sent
TcpExt:
    710 packets pruned from receive queue because of socket buffer overrun
    ArpFilter: 0
    288 TCP sockets finished time wait in fast timer
    4670 delayed acks sent
    1 delayed acks further delayed because of locked socket
    Quick ack mode was activated 2 times
    15351 packets directly queued to recvmsg prequeue.
    1705 packets directly received from backlog
    18950299 packets directly received from prequeue
    8239472 packets header predicted
    12409 packets header predicted and directly queued to user
    TCPPureAcks: 2219
    TCPHPAcks: 262896
    TCPRenoRecovery: 4
    TCPSackRecovery: 0
    TCPSACKReneging: 0
    TCPFACKReorder: 0
    TCPSACKReorder: 0
    TCPRenoReorder: 0
    TCPTSReorder: 0
    TCPFullUndo: 0
    TCPPartialUndo: 0
    TCPDSACKUndo: 0
    TCPLossUndo: 0
    TCPLoss: 0
    TCPLostRetransmit: 0
    TCPRenoFailures: 0
    TCPSackFailures: 0
    TCPLossFailures: 0
    TCPFastRetrans: 4
    TCPForwardRetrans: 0
    TCPSlowStartRetrans: 1
    TCPTimeouts: 37
    TCPRenoRecoveryFail: 2
    TCPSackRecoveryFail: 0
    TCPSchedulerFailed: 0
    TCPRcvCollapsed: 26548
    TCPDSACKOldSent: 0
    TCPDSACKOfoSent: 0
    TCPDSACKRecv: 0
    TCPDSACKOfoRecv: 0
    TCPAbortOnSyn: 0
    TCPAbortOnData: 36
    TCPAbortOnClose: 7
    TCPAbortOnMemory: 0
    TCPAbortOnTimeout: 0
    TCPAbortOnLinger: 0
    TCPAbortFailed: 0
    TCPMemoryPressures: 0
[root@dragon backups]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:02:B3:D8:C8:D6
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:20 Base address:0x8400 Memory:f8341000-f8341038

eth1      Link encap:Ethernet  HWaddr 00:02:B3:D8:C8:26
          inet addr:192.168.123.139  Bcast:192.168.123.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8447477 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4376770 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3510576048 (3347.9 Mb)  TX bytes:412714386 (393.5 Mb)
          Base address:0x8440 Memory:f8320000-f8340000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3135 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5987029 (5.7 Mb)  TX bytes:5987029 (5.7 Mb)

[root@dragon backups]# date
Wed Jan 26 10:59:40 PST 2005
[root@dragon backups]# date
Wed Jan 26 11:07:02 PST 2005
[root@dragon backups]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:02:B3:D8:C8:D6
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:20 Base address:0x8400 Memory:f8341000-f8341038

eth1      Link encap:Ethernet  HWaddr 00:02:B3:D8:C8:26
          inet addr:192.168.123.139  Bcast:192.168.123.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13046186 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6661196 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1511534204 (1441.5 Mb)  TX bytes:562524871 (536.4 Mb)
          Base address:0x8440 Memory:f8320000-f8340000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3135 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5987029 (5.7 Mb)  TX bytes:5987029 (5.7 Mb)

[root@dragon backups]# netstat -s
Ip:
    13028144 total packets received
    0 forwarded
    0 incoming packets discarded
    13027925 incoming packets delivered
    6663158 requests sent out
Icmp:
    8 ICMP messages received
    2 input ICMP message failed.
    ICMP input histogram:
        destination unreachable: 5
        echo requests: 3
    8 ICMP messages sent
    0 ICMP messages failed
    ICMP output histogram:
        destination unreachable: 5
        echo replies: 3
Tcp:
    167 active connections openings
    353 passive connection openings
    2 failed connection attempts
    7 connection resets received
    4 connections established
    13023790 segments received
    6662132 segments send out
    49 segments retransmited
    0 bad segments received.
    110 resets sent
Udp:
    4169 packets received
    0 packets to unknown port received.
    0 packet receive errors
    1018 packets sent
TcpExt:
    1433 packets pruned from receive queue because of socket buffer
overrun
    ArpFilter: 0
    288 TCP sockets finished time wait in fast timer
    5053 delayed acks sent
    1 delayed acks further delayed because of locked socket
    Quick ack mode was activated 2 times
    15354 packets directly queued to recvmsg prequeue.
    1705 packets directly received from backlog
    18950299 packets directly received from prequeue
    12813569 packets header predicted
    12409 packets header predicted and directly queued to user
    TCPPureAcks: 2225
    TCPHPAcks: 348113
    TCPRenoRecovery: 4
    TCPSackRecovery: 0
    TCPSACKReneging: 0
    TCPFACKReorder: 0
    TCPSACKReorder: 0
    TCPRenoReorder: 0
    TCPTSReorder: 0
    TCPFullUndo: 0
    TCPPartialUndo: 0
    TCPDSACKUndo: 0
    TCPLossUndo: 0
    TCPLoss: 0
    TCPLostRetransmit: 0
    TCPRenoFailures: 0
    TCPSackFailures: 0
    TCPLossFailures: 0
    TCPFastRetrans: 4
    TCPForwardRetrans: 0
    TCPSlowStartRetrans: 1
    TCPTimeouts: 41
    TCPRenoRecoveryFail: 2
    TCPSackRecoveryFail: 0
    TCPSchedulerFailed: 0
    TCPRcvCollapsed: 53890
    TCPDSACKOldSent: 0
    TCPDSACKOfoSent: 0
    TCPDSACKRecv: 0
    TCPDSACKOfoRecv: 0
    TCPAbortOnSyn: 0
    TCPAbortOnData: 36
    TCPAbortOnClose: 7
    TCPAbortOnMemory: 0
    TCPAbortOnTimeout: 0
    TCPAbortOnLinger: 0
    TCPAbortFailed: 0
    TCPMemoryPressures: 0
[root@dragon backups]# ethtool -S eth0
NIC statistics:
     rx_packets: 0
     tx_packets: 0
     rx_bytes: 0
     tx_bytes: 0
     rx_errors: 0
     tx_errors: 0
     rx_dropped: 0
     tx_dropped: 0
     multicast: 0
     collisions: 0
     rx_length_errors: 0
     rx_over_errors: 0
     rx_crc_errors: 0
     rx_frame_errors: 0
     rx_fifo_errors: 0
     rx_missed_errors: 0
     tx_aborted_errors: 0
     tx_carrier_errors: 0
     tx_fifo_errors: 0
     tx_heartbeat_errors: 0
     tx_window_errors: 0
     tx_late_collision_errors: 0
     tx_deferred: 0
     tx_single_collisions: 0
     tx_multi_collisions: 0
     rx_collision_detected_errors: 0
     tx_flow_control_pause: 0
     rx_flow_control_pause: 0
     rx_flow_control_unsupported: 0
     tx_tco_packets: 0
     rx_tco_packets: 0
Comment 3 Suzanne Hillman 2005-02-08 14:16:47 EST
Closing as per comment #2.

Note You need to log in before you can comment on or make changes to this bug.