Bug 143939 - No match for Epson Stylus Photo R300 from printer config
No match for Epson Stylus Photo R300 from printer config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
: 145878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-01 19:22 EST by Chris Bagwell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 10:39:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_R300.xml (1.76 KB, text/plain)
2005-01-04 11:50 EST, Tim Waugh
no flags Details

  None (edit)
Description Chris Bagwell 2005-01-01 19:22:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The following message is printed when running system-config-printer. 
I do have an Epson Stylus Photo R300 USB printer plugged in and there
are printer drivers in Fedora Core 3 for it.

No match for USB device:
  mfr "EPSON"
  model "Stylus Photo R300"
  desc "EPSON Stylus Photo R300"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-printer
2.
3.
    

Additional info:
Comment 1 Chris Bagwell 2005-01-02 14:01:00 EST
Little extra information on reproducing this.

I have a pre-existing Epson R300 configured using the
system-config-printer tool.  Its a USB printer but the device is using
"hal:" instead of /dev/usb/lp0 that was used in previous releases. 
Since I did not run the tool from the command line when I first
created the printer, I don't know if it printed the messages then.

If I select "Edit" from system-config-printer, thats when I get the
text output requesting to bugzilla it.
Comment 2 Tim Waugh 2005-01-04 11:50:03 EST
Created attachment 109332 [details]
/usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_R300.xml

Please save this attachment and copy it to:

  /usr/share/foomatic/db/source/printer/Epson-Stylus_Photo_R300.xml

Is the correct model automatically selected now?
Comment 3 Chris Bagwell 2005-01-04 20:02:30 EST
Yes, the above attachment with the new <usb></usb> info made the errro text
message stop printing... 

Also, when I looked at the "Queue Type" screen in syste-config-printer, the
/dev/usb/lp0 has the phrase "EPSON Stylus Photo R300" beside it which I think is
new.  The "autoselect" button on the same screen also correctly selects the
right driver.
  
Thank you for your help.
Comment 4 Tim Waugh 2005-01-05 07:33:06 EST
How about if you click "Next" on that screen?  It should select the correct
model from the list.
Comment 5 Chris Bagwell 2005-01-05 10:21:08 EST
I don't see a "Next" button but I think its doing what your asking.

Selecting "Edit" button from system-config-printer on an existing printer takes
me to a window and I get no error text any more on terminal window I ran it from
.  Selecting the "Queue Type" tab I then select Locally-connected and
/dev/usb/lp0.  Next I click the "autoselect" button and it takes me to the
Printer Driver tab with the Stylus Photo R300 correctly selected.

Alternate path that also started working with attachment:  I create a new
printer by clicking on the "New" button on system-config-printer.  I click
"Forward" twice, then select "Locally-connected" and "/dev/usb/lp0".  Clicking
"Forward" button again takes me to a screen that has the Epson Stylus Photo R300
selected.

I assume by "Next" you meant "Forward" on the create printer screen.  Yes, this
started auto-selecting correct driver when I used to manually select the driver
when creating the queue.

I have system-config-printer-0.6.116-1 in case that is of interest.

Thanks again,
Chris
Comment 6 Tim Waugh 2005-01-05 10:39:59 EST
> Clicking "Forward" button again takes me to a screen that has the Epson
> Stylus Photo R300 selected.

Ah, Forward is what I meant.  Thanks.
Comment 7 Tim Waugh 2005-01-23 04:01:14 EST
*** Bug 145878 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.