Bug 143943 - Logwatch don't care about many FreeS/WAN messages
Logwatch don't care about many FreeS/WAN messages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 04:23 EST by Peter Bieringer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 07:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-01-02 04:23:14 EST
Description of problem:
Logwatch contain already a check for the output of pluto, the *S/WAN IKE daemon:
/etc/log.d/scripts/services/pluto

But it doesn't suppress information, which is only informational.

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1

How reproducible:
Always

Steps to Reproduce:
1. Setup openswan ipsec
2. Run openswan ipsec
3. Run logwatch
    

Actual Results:  Many of such messages:

UNKNOWN: Jan  1 04:28:25 *** pluto[6161]: "***" #17: transition from state (null) to state 
STATE_MAIN_R1
UNKNOWN: Jan  1 04:28:25 *** pluto[6161]: "***" #17: transition from state 
STATE_MAIN_R1 to state STATE_MAIN_R2
UNKNOWN: Jan  1 04:28:25 *** pluto[6161]: "***" #17: Peer ID is ID_IPV6_ADDR: '2001:
6f8:****'
UNKNOWN: Jan  1 04:28:25 *** pluto[6161]: "***" #17: I did not send a certificate because 
I do not have one.
UNKNOWN: Jan  1 04:28:25 *** pluto[6161]: "***" #17: transition from state 
STATE_MAIN_R2 to state STATE_MAIN_R3
UNKNOWN: Jan  1 06:15:10 *** pluto[6161]: "***" #18: received Delete SA payload: 
deleting ISAKMP State #18


Expected Results:  Suppressing of such messages

Additional info:
Comment 1 Ivana Varekova 2005-06-30 07:27:29 EDT
/etc/log.d/scripts/services/pluto should scan FreeSWAN log file. FreeSWAN is no
longer in active development. So logwatch upstream don't develope pluto script too. 
So it does not expect openswan log file and create some extra messages.
Ivana Varekova


Note You need to log in before you can comment on or make changes to this bug.