This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 143944 - system-config-display fails on line 388
system-config-display fails on line 388
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 05:45 EST by James Richardson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-13 13:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of kudzu -p -b video (7.35 KB, text/plain)
2005-01-05 01:00 EST, James Richardson
no flags Details
Output of lspci -vv (21.91 KB, text/plain)
2005-01-05 01:01 EST, James Richardson
no flags Details

  None (edit)
Description James Richardson 2005-01-02 05:45:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

Description of problem:
After failing to detect my video card when installing, attempting to run system-config-display producing the an error message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 3
2. Run system-config-display

  

Actual Results:  Received the following error message

Traceback (most recent call list)
File '/usr/share/system-display-config/xconf.py' , line 388 , in ?
hardware_state.merge_into(xconfig)
Name Error: name 'hardware_state' is not defined

Expected Results:  A completed and working xorg configuation file.

Additional info:

Problem still occurs after doing a full yum update yesterday. The 3D card is a ATi Radeon X700 PCI Express. It may also be worth noting that fedora has not created an xorg configation file during the install either.
Comment 1 Paul Nasrat 2005-01-03 11:57:44 EST
What does running as root:

kudzu -p -b video

give. Can you attach the output of lspci -vv. I've fixed it tracing back in cvs
but I want to figure why we aren't picking up your card.
Comment 2 James Richardson 2005-01-05 01:00:30 EST
Created attachment 109356 [details]
Output of kudzu -p -b video
Comment 3 James Richardson 2005-01-05 01:01:12 EST
Created attachment 109357 [details]
Output of lspci -vv
Comment 4 Calum Polwart 2005-05-21 09:58:10 EDT
I am able to reproduce this bug identically.

Bug occurs when Anaconda fails to recognise a video card and/or monitor and
consequently performs a 'headless' installation.

I have read of several others with the same report 9although sometimes a later
line number.

If you can't install the video card through anaconda nor through
system-config-display it doesn't leave you any options.  This could be fixed two
ways:

1. Fix anaconda to allow manual selection of video card when not detected
instead of reverting to text install

2. Fix the bug in system-config-display that requires some previous hardware
information.

The solution is not to detect the video card - there are too many possibilities
out there.

I have tried version 1.0.27-1 which *CLAIMED* to have a fix for hardware_state
if it didn't exist.

I am unable to attach the kudzu report as I can't get into a web browser from
the broken machine, and it doesn't have any recordable media on it, however briefly:


-
CLass VIDEO
bus PCI
detached 0
driver: unknown
desc "silicon integrated systems [SiS] 300/305 PCI/AGP VGA Display Adapter"
Vendor: 1039
Device: 0300
SubVendor: 1039
SubDevice: 0300
PCI Type: 1
PCI Dom: 0
PCIBus: 1
PCIDev: 0
PCIfn: 0

Comment 5 John Thacker 2007-01-13 13:19:59 EST
Pretty sure that this is fixed now.
xconf.py now sets hardware_state to None before trying to read it from the
configuration file, and also tests to see if hardware_state exists before
merging it into xconfig

I'm not sure exactly when it was fixed.  I'm sorry that no one got to closing
this bug earlier.  If it's still a problem, please reopen.

Note You need to log in before you can comment on or make changes to this bug.