Bug 143948 - bad font in pdf files
Summary: bad font in pdf files
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf   
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-02 13:01 UTC by Rick Richardson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 10:48:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test file (95.16 KB, application/octet-stream)
2005-01-02 13:04 UTC, Rick Richardson
no flags Details
Microsoft authored pdf (123.55 KB, application/octet-stream)
2005-01-06 02:06 UTC, Rick Richardson
no flags Details
Proof that it contains the fonts. (108.67 KB, image/gif)
2005-01-06 03:14 UTC, Rick Richardson
no flags Details

Description Rick Richardson 2005-01-02 13:01:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:

$ acroread 0011366.pdf

Error: /invalidfont in -dict-
Operand stack:
   OHFMTT+Helvetica-Condensed-Black-Identity-H   --dict:8/10(L)--  
Font   OHFMTT+Helvetica-Condensed-Black-Identity-H   --dict:8/10(L)--
  OHFMTT+Helvetica-Condensed-Black-Identity-H
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   false   1   %stopped_push   1   3
  %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3 
 %oparray_pop   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   3   8  
%oparray_pop   3   8   %oparray_pop   --nostringval--  
--nostringval--   --nostringval--   7   9   %oparray_pop  
--nostringval--   7   9   %oparray_pop   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1061/1123(ro)(G)--   --dict:0/20(G)--   --dict:95/200(L)-- 
 --dict:44/89(L)--   --dict:79/160(ro)(L)--   --dict:63/78(ro)(L)--  
--dict:8/25(L)--   --dict:27/35(ro)(L)--   --dict:17/17(ro)(G)--
Current allocation mode is local
Last OS error: 2
GNU Ghostscript 7.07: Unrecoverable error, exit code 1


$ acroread 0011366.pdf

Comment 1 Rick Richardson 2005-01-02 13:04:06 UTC
Created attachment 109234 [details]
Test file

Comment 2 Sitsofe Wheeler 2005-01-02 15:22:32 UTC
Rick,
Can you give the steps you followed to create that pdf?

Comment 3 Rick Richardson 2005-01-02 19:41:58 UTC
Sorry, this is a Symantec pdf.  

Comment 4 Tim Waugh 2005-01-04 17:21:34 UTC
What does that mean?  How was the PDF created?

Comment 5 Rick Richardson 2005-01-06 02:03:36 UTC
And another one: this time by Microsoft.

Comment 6 Rick Richardson 2005-01-06 02:06:02 UTC
Created attachment 109408 [details]
Microsoft authored pdf

Comment 7 Rick Richardson 2005-01-06 02:07:49 UTC
Microsoft output:

Error: /invalidfont in -dict-
Operand stack:
   OVIXIY+FranklinGotT-Demi-Identity-H   --dict:8/10(L)--   Font  
OVIXIY+FranklinGotT-Demi-Identity-H   --dict:8/10(L)--  
OVIXIY+FranklinGotT-Demi-Identity-H
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   false   1   %stopped_push   1   3
  %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3 
 %oparray_pop   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   3   8  
%oparray_pop   3   8   %oparray_pop   --nostringval--  
--nostringval--   --nostringval--   7   9   %oparray_pop  
--nostringval--   7   9   %oparray_pop   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1061/1123(ro)(G)--   --dict:0/20(G)--   --dict:95/200(L)-- 
 --dict:44/89(L)--   --dict:79/160(ro)(L)--   --dict:63/78(ro)(L)--  
--dict:8/25(L)--   --dict:27/35(ro)(L)--   --dict:17/17(ro)(G)--
Current allocation mode is local
Last OS error: 2
GNU Ghostscript 7.07: Unrecoverable error, exit code 1

Comment 8 Rick Richardson 2005-01-06 03:14:46 UTC
Created attachment 109410 [details]
Proof that it contains the fonts.

Comment 9 Sitsofe Wheeler 2005-01-06 14:49:40 UTC
Rick, I think part of the problem is that you are reporting a problem which is occuring in a piece of software not shipped in Fedora (acroread). acroread may well use ghostscript but it's impossible to tell whether it is using it correctly without the source for acroread so you are better off talking to Adobe about problems stemming from acroread (directly or indirectly).

Fedora ships with several programs capable of reading pdfs (gv, ggv, gpdf, xpdf, kpdf ...) so you always have the option of filing an individual bug against one of those if the problem persists (although the warning seems fairly harmless if you can view the pdf).

Comment 10 Rick Richardson 2005-01-06 15:17:15 UTC
Try xpdf on the file and it is worse.  !!!!!!!

Comment 11 Tim Waugh 2005-01-06 15:22:01 UTC
Running 'gs -sDEVICE=x11 2552.pdf' on your test case works fine here.

I've changed the component to xpdf and reassigned.

Comment 12 Rick Richardson 2005-01-06 16:01:20 UTC
This only fixes one problem.

Acroread output is fine, but not processed with ghostscript.

Comment 13 Ngo Than 2005-02-02 10:48:24 UTC
it's now fixed in 3.00-10.3, the new package will be pushed as update for FC3
this week. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.