Bug 143958 - No match for EPSON Stylus C80
No match for EPSON Stylus C80
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 12:41 EST by Jon Hobden
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 18:28:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Hobden 2005-01-02 12:41:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
FC3 fully up2date

Attempting to configure Epson C80 on USB via the GUI, all goes through
till you hit "finish", when nothing happens.

So run system-config-printer and you get:
$ system-config-printer
No match for USB device:
  mfr "EPSON"
  model "Stylus C80"
  desc "EPSON Stylus C80"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. New install of FC3 from Linux Format Jan 2005
2. Run up2date (2 Jan 05)
3. System settings | Printing - fails at finish
4. Console $ system-config-printer - error message above
    

Additional info:

This printer worked happily under FC1
Comment 1 Tim Waugh 2005-01-04 08:57:24 EST
This ID is included upstream and in rawhide (but not in FC3).

It should not be preventing you from printing, however -- can you confirm that
printing is working with that printer?
Comment 2 Jon Hobden 2005-01-04 14:42:46 EST
As far as i can tell - no it's not.   Like a fool, I skipped the
"print test page" option when doing the latest installation.

However, lpr complains:
lpr: error - no default destination available.

and apps such as OOo or gedit offer only "Create a PDF Doc" (which
works) or "Generic Postscript" (which seems to go to the bitbucket) in
the Printers list.

If I hot plug the USB cable after it's been disconnected a while, it
kicks in the GUI printer selection app, which correctly identifies
Epson in the manufacturer list and Stylus C80, but doesn't create an
entry in the Printers list.

Is there a printer definitions file on the FC1 distro that I could
copy/hack to get this working for now?   I'm sorry, I'm fairly new to
Linux, but I've been dabbling on a spare test box for a few months,
and i'm just about convinced I could make the big leap some time soon.

Thanks

Comment 3 Jon Hobden 2005-01-04 15:01:40 EST
Latest

I have just tried system-config-printer again, and now get the following:

]# system-config-printer
No match for USB device:
  mfr "EPSON"
  model "Stylus C80"
  desc "EPSON Stylus C80"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
XML error: Nested angle brackets in
/usr/share/foomatic/db/source/opt/gimp-print -ijs-pagesize.xml, line
89795!
Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 1257, in finish
    self.queue_data, driver_tuple)
  File "/usr/share/printconf/util/printconf_conf.py", line 968, in
construct_que ue
    printer.id, gs_driver)
  File "/usr/share/printconf/util/printconf_conf.py", line 807, in
foomatic_set_ default_page_size
    for opt in drv.options.values():
AttributeError: 'NoneType' object has no attribute 'options'

Spot my deliberate mistake first time?   I had forgotten to su before
running the command.   I hope this helps  - Jon
Comment 4 Tim Waugh 2005-01-05 07:00:54 EST
You don't need to run 'su' before running the command.  However, the traceback
is entirely unexpected.

What does this say?:

  rpm -V foomatic
Comment 5 Jon Hobden 2005-01-06 13:20:29 EST
$ rpm -V foomatic
..5......   /usr/share/foomatic/db/source/opt/gimp-print-ijs-pagesize.xml
Comment 6 Tim Waugh 2005-01-06 18:28:25 EST
That means that the file has been modified since installation.
Comment 7 Jon Hobden 2005-01-08 10:16:42 EST
Thank you - sorted.

I don't know what had modified it but reinstalling from DVD:

[root@mead RPMS]#  rpm -ivh --replacepkgs foomatic-3.0.2-3.i386.rpm
Preparing...               
########################################### [100%]
   1:foomatic              
########################################### [100%]
[root@mead RPMS]# system-config-printer
No match for USB device:
  mfr "EPSON"
  model "Stylus C80"
  desc "EPSON Stylus C80"
  cmdset "ESCPL2,BDC,D4"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Use of deprecated SAXv1 function endElement

Same error, but as you said, I can now print to it.   That's good
enough for me;  thanks for your help and patience.

Jon
Comment 8 Tim Waugh 2005-01-10 03:59:08 EST
Great.  The remaining messages are dealth with in the rawhide foomatic package.

Note You need to log in before you can comment on or make changes to this bug.