Bug 144009 - mkinitrd fails when POSIXLY_CORRECT env variable is set
mkinitrd fails when POSIXLY_CORRECT env variable is set
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 13:19 EST by Jay Pharis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-06 16:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Pharis 2005-01-03 13:19:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I had set POSIXLY_CORRECT=1 in /etc/profile and /etc/bashrc.  When I
ran up2date to install the latest kernels, mkinitrd fails with the
following:

awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension
awk: cmd. line:2: fatal: match: third argument is a gawk extension 

In addition, unless the env variable _POSIX2_VERSION is set to some
other value (I used 199209),  also get the following tail error from
mkinitrd:

tail: `-1' option is obsolete; use `-n 1'
Try `tail --help' for more information. 

I created a support request with this information, 452082.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set the env variables listed above
2. run up2date, or just mkinitrd
3. profit
    

Actual Results:  see above

Additional info:
Comment 1 Peter Jones 2005-06-06 16:06:45 EDT
Don't do that.
Comment 2 Need Real Name 2006-04-12 15:15:02 EDT
Well, as smart as that answer/solution was, there SEEMS to be a problem WHEN
this variable is set, --and-- it seems to BE in the kickstart environment.

I was attempting to pre-load a kernel update within kickstart and this SAME
error occured.  I would have had no idea the cause it it wasn't for this post of
Jay Pharis.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.