Bug 144020 - glibmm24-devel package does not contain libtool libs
glibmm24-devel package does not contain libtool libs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibmm24 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 15:11 EST by Johan Bondeson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 17:47:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from failing config / build of gtkglextmm (10.90 KB, text/plain)
2005-01-03 16:43 EST, Johan Bondeson
no flags Details
successful build log (7.50 KB, application/x-gzip)
2005-01-03 17:25 EST, Michael Schwendt
no flags Details

  None (edit)
Description Johan Bondeson 2005-01-03 15:11:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
The package does not contain libtool libraries (.la files). Trying to compile gtkglextmm-1.3 from original sources (which compiled fine on fc2) looks like this:

/bin/sh ../../libtool --mode=link g++  -g -O2 -Wall   -o generate_extra_defs  generate_defs_gtkglext.o  -Wl,--export-dynamic -L/usr/X11R6/lib -lgtkglext-x11-1.0 -lgdkglext-x11-1.0 -lGLU -lGL -lXmu -lXt -lSM -lICE -lgtkmm-2.4 -lgdkmm-2.4 -latkmm-1.6 -lgtk-x11-2.0 -lpangomm-1.4 -lglibmm-2.4 -lsigc-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0      -lglibmm_generate_extra_defs-2.4
libtool: link: cannot find the library `/usr/lib/libglibmm-2.4.la'

looking at rpm -q --filesbypkg I find no .la files.

This is kind of irritating because a lot of software use libtool.

Version-Release number of selected component (if applicable):
glibmm24-2.4.5-1 glibmm24-devel-2.4.5-1

How reproducible:
Always

Steps to Reproduce:
Try to compile software that uses libtool and glibmm24


Actual Results:  Linking error. Cannot find /usr/lib/libglibmm-2.4.la

Expected Results:  The libtool lib should be there.

Additional info:
Comment 1 Michael Schwendt 2005-01-03 15:37:37 EST
Cannot reproduce. The libtool archives are not needed. Please attach
full session build log.

$ md5sum gtkglextmm-1.3.0.tar.bz2 
15875bbe8ef3dd52e1fb8ca8d4101d21  gtkglextmm-1.3.0.tar.bz2
Comment 2 Johan Bondeson 2005-01-03 16:43:17 EST
Created attachment 109286 [details]
Log from failing config / build of gtkglextmm
Comment 3 Johan Bondeson 2005-01-03 16:45:01 EST
Strange. I do
% ./configure --prefix=/usr
% make
and it gives me that error opun the first linking.
I attached a log.
Comment 4 Michael Schwendt 2005-01-03 17:25:28 EST
Created attachment 109292 [details]
successful build log

Here's the successful build. Maybe you installed something from source code
which is the culprit.
Comment 5 Johan Bondeson 2005-01-03 17:47:30 EST
Well, obviusly I had messed something up. I reinstalled gtkmm24 and
gtkglext and everything compiled fine. Just out of curiosity, what
causes such behaviour (that the linker requires those .la libs)?
Thanks anyway...
Comment 6 Michael Schwendt 2005-01-03 17:56:14 EST
Sometimes: references to libtool convenience libraries or incorrectly
installed libtool archives which include hardcoded inter-library
dependencies.

Note You need to log in before you can comment on or make changes to this bug.