Bug 144062 - service unable to start process
service unable to start process
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: serviceconf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2005-01-04 05:09 EST by Klas Pettersson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-04 09:30:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Klas Pettersson 2005-01-04 05:09:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.0.3705)

Description of problem:
I´ve created a initscript, gada_cp, in /etc/init.d and installed it 
with the chkconfig --add command.

When i try to start it using the GUI serviceconf or the 
command "service gada_cp start" it returns:
"Starting gada_cp:  [OK]"
But "service --status gada_cp" returns "gada_cp dead but subsys 
I am able to start the process by executing the initscript directly:
"/etc/init.d/gada_cp start"
Then it starts and stops normaly and runs perfectly. This is true for 
all commands, start|stop|restart|condrestart.
I´ve tried to remove the the /var/lock/subsys/gada_cp file and 
restarting using the service command but with the same outcome as 
Worth noting is that when I start the process 
with /etc/init.d/gada_cp start I can stop it with "service gada_cp 
stop" but not restart or start.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.create initscript and install with "chkconfig"
2.start it with service or serviceconf
3.start it directly by executing the /etc/init.d/*** file

Actual Results:  gada_cp dead but subsys locked

Expected Results:  gada_cp (PID) is running...

Additional info:
Comment 1 Daniel Walsh 2005-01-04 09:30:11 EST
Looks like you have a problem in you init script.

/etc/init.d/gada_cp status 
is returning bad data.

Comment 2 Klas Pettersson 2005-01-11 02:01:10 EST
But when I issue the command /etc/init.d/gada_cp status it returns 
the proper value...
The script works fine as long I don´t start it with the command 
Comment 3 Daniel Walsh 2005-01-11 09:31:19 EST
you can do a sh -x service gada_cp start and see what service is
doing.  It is just a script.

For example

sh -x service nfs restart

Ends up executing
 env -i LANG=en_US.UTF-8
PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin TERM=xterm
/etc/init.d/nfs restart

Comment 4 Klas Pettersson 2005-01-12 03:49:57 EST
Great command for future usage. We´ve had problems with frequent 
system hangings on ES 3.0 with the 2.4.21-9 Kernel so we suspected 
memory leakage and upgraded to 2.4.21-27. After that upgrade and the 
following reboot it (the initscript starting with service)started to 
work. I guess that has nothing to do with it but nothing else where 
touched or changed. Strange... Well, that problem solved though...

Thanks a lot...

Note You need to log in before you can comment on or make changes to this bug.