Bug 144089 - Totem fails to play Ogg Theora version of World of Warcraft trailer
Totem fails to play Ogg Theora version of World of Warcraft trailer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 09:34 EST by David Nielsen
Modified: 2013-03-13 00:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 16:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2005-01-04 09:34:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041220 Epiphany/1.4.7

Description of problem:
Christian F.K. Schaller converted the world of warcraft trailer to Ogg
Theora and I thought it would make a good test case for totem, but our
totem just displays a blank screen when I feed it the file. 
It was converted using gstreamer, and it plays on Ubuntu Hoary's totem
so there's something wrong with the current configuration.

Link to the file in question:
http://www.linuxrising.org/files/world_of_warcraft_m480.ogg

Version-Release number of selected component (if applicable):
totem-0.100-1

How reproducible:
Always

Steps to Reproduce:
1. play file


Actual Results:  Observ blank totem window, length of clip correctly
detected

Expected Results:  Playback

Additional info:

System updated to Development as of 04-01-05
Comment 1 sangu 2005-01-06 13:00:03 EST
played http://www.linuxrising.org/files/world_of_warcraft_m480.ogg 
with totem-0.100-2.

(gdb) bt
#0  0x0025f7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00371dac in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
#2  0x003675d0 in ?? () from /usr/lib/libgthread-2.0.so.0
#3  0x09d34950 in ?? ()
#4  0x09d351b0 in ?? ()
#5  0xbff59bf8 in ?? ()
#6  0x00491d2e in gst_debug_log () from /usr/lib/libgstreamer-0.8.so.1
#7  0x004b2c24 in gst_thread_get_current () from /usr/lib/libgstreamer-0.8.so.1
#8  0x0048bb06 in gst_element_wait_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#9  0x0047e672 in gst_bin_set_state () from /usr/lib/libgstreamer-0.8.so.1
#10 0x0048b187 in gst_element_set_state () from /usr/lib/libgstreamer-0.8.so.1
#11 0x0047e11a in gst_bin_child_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#12 0x0047e038 in gst_bin_child_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#13 0x0047e47a in gst_bin_child_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#14 0x004b3117 in gst_thread_get_current () from /usr/lib/libgstreamer-0.8.so.1
#15 0x0048bb06 in gst_element_wait_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#16 0x0047e672 in gst_bin_set_state () from /usr/lib/libgstreamer-0.8.so.1
---Type <return> to continue, or q <return> to quit---
#17 0x0048b187 in gst_element_set_state () from /usr/lib/libgstreamer-0.8.so.1
#18 0x00dd3b2e in gst_play_base_bin_get_streaminfo ()
   from /usr/lib/gstreamer-0.8/libgstplaybin.so
#19 0x00dd0cc0 in ?? () from /usr/lib/gstreamer-0.8/libgstplaybin.so
#20 0x09993990 in ?? ()
#21 0x095e1bd8 in ?? ()
#22 0x004cd1bd in ?? () from /usr/lib/libgstreamer-0.8.so.1
#23 0x004ce0f9 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#24 0x00000ae7 in ?? ()
#25 0x0807ff84 in _gst_bin_type ()
#26 0x09993990 in ?? ()
#27 0x0057e3b4 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#28 0x0807ff84 in _gst_bin_type ()
#29 0x00000004 in ?? ()
#30 0xbff5a0e8 in ?? ()
#31 0x0048bb06 in gst_element_wait_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#32 0x0048bb06 in gst_element_wait_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#33 0x0048b187 in gst_element_set_state () from /usr/lib/libgstreamer-0.8.so.1
#34 0x0805f8f6 in bacon_video_widget_pause ()
#35 0x08066613 in totem_action_play_pause ()
#36 0x005b22fd in g_cclosure_marshal_VOID__VOID ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libgobject-2.0.so.0
#37 0x0059ce48 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#38 0x005b0bee in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#39 0x005b1c7e in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#40 0x005b1f34 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#41 0x009ba1ba in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#42 0x009bb9cd in gtk_button_get_alignment () from /usr/lib/libgtk-x11-2.0.so.0
#43 0x005b22fd in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#44 0x0059d0dd in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#45 0x0059ce48 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#46 0x005b056d in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#47 0x005b1c7e in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#48 0x005b1f34 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#49 0x009ba126 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#50 0x009bb057 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#51 0x00a7899b in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#52 0x0059d0dd in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#53 0x0059ce48 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#54 0x005b0783 in g_signal_has_handler_pending ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libgobject-2.0.so.0
#55 0x005b19bf in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#56 0x005b1f34 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#57 0x00b5af38 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#58 0x00a77137 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#59 0x00a77407 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#60 0x0032e192 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#61 0x0066a178 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#62 0x0066b998 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#63 0x0066bcbf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#64 0x00a767f6 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#65 0x08069c63 in main ()
(gdb)

Comment 2 sangu 2006-01-27 12:41:22 EST
This problem was fixed in totem 1.3.1.
Comment 3 John Thacker 2006-04-14 16:06:30 EDT
This is definitely fixed since totem 1.3.1.  Closing.

Note You need to log in before you can comment on or make changes to this bug.