Bug 144107 - Openssh doesn't need pam_nologin
Summary: Openssh doesn't need pam_nologin
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-04 16:54 UTC by Tomas Mraz
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: openssh-4.1p1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 21:47:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Mraz 2005-01-04 16:54:14 UTC
In the /etc/pam.d/sshd there is 'auth required pam_nologin.so' line.

This is however unnecessary because the functionality of this pam
module is duplicated in the sshd source. And the nologin message of
pam_nologin isn't printed. Note that you need pam_nologin of FC2 and
older because of the bug 143750 which efectively disables pam_nologin
for sshd.

The pam_nologin should be removed from the /etc/pam.d/sshd.

Comment 1 Tomas Mraz 2005-06-09 21:47:37 UTC
Fixed the other way around - the direct /etc/nologin processing by sshd was
removed if UsePAM is yes (the default).


Comment 2 Dax Kelson 2006-02-01 17:43:57 UTC
(In reply to comment #1)
> Fixed the other way around - the direct /etc/nologin processing by sshd was
> removed if UsePAM is yes (the default).

Was this done with a RH specific patch?

The new (Feb 2006) release of OpenSSH v4.3 does exactly this.

Comment 3 Tomas Mraz 2006-02-01 18:06:57 UTC
The upstream fix was based on the FC patch.



Note You need to log in before you can comment on or make changes to this bug.