Bug 144109 - (IT_69560) latest quota package is broken
latest quota package is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: quota (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
: Regression
: 147349 148853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 11:59 EST by Ivan Valtchanov
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 14:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fixes the incompatability with version 1 rquotad (453 bytes, patch)
2005-03-07 10:41 EST, Chris Feist
no flags Details | Diff

  None (edit)
Description Ivan Valtchanov 2005-01-04 11:59:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The latest errata of the quota package (quota-3.10-4) is broken as it
reports the following error:  

quota: Error while getting quota from nfs_server:/dir for UID: Invalid
argument

instead of giving the user's quota.

It worked just fine with quota-3.09-1. 

Systems affected: from i386, i586, i686, x86_64.

Version-Release number of selected component (if applicable):
quota-3.10.4

How reproducible:
Always

Steps to Reproduce:
1. Mount one Solaris NFS filesystem with quota
2. quota -v (on Linux)

    

Actual Results:  quota: Error while getting quota from nfs_server:/dir
for UID: Invalid argument


Expected Results:  Disk quotas for user USER (uid UID):
     Filesystem  blocks   quota   limit   grace   files   quota  
limit   grace
nfs_server:/export/home/USER
                1650256  1998000 2000000           10598   19800   20000


Additional info:
Comment 1 Brian Dourty 2005-01-10 15:53:59 EST
We are also experiancing this bug. We have 4 RHEL 3.0 Update 4 servers
that mount a filesystem via NFS to a FreeBSD 4.9-STABLE server. Quota
version quota-3.09-1 worked fine. Quota version quota-3.10-4 results
in the following error.

quota -v USERNAME
quota: Error while getting quota from HOSTNAME:/FS for UID: Invalid
argument
Disk quotas for user USERNAME (uid UID): none
Comment 2 Jussi Silvennoinen 2005-01-18 13:32:47 EST
A me-too report, our problems are against a NetApp-filer.
Comment 3 Chris Feist 2005-01-19 17:53:20 EST
Can you please post the output of this commane - 'rpcinfo -p
nfs_server_name'
Comment 4 Jussi Silvennoinen 2005-01-20 02:26:23 EST
   program vers proto   port
    100011    1   udp   4049  rquotad
    100021    4   tcp   4045  nlockmgr
    100021    3   tcp   4045  nlockmgr
    100021    1   tcp   4045  nlockmgr
    100021    4   udp   4045  nlockmgr
    100021    3   udp   4045  nlockmgr
    100021    1   udp   4045  nlockmgr
    100024    1   tcp   4047  status
    100024    1   udp   4047  status
    100005    3   tcp   4046  mountd
    100005    2   tcp   4046  mountd
    100005    1   tcp   4046  mountd
    100005    3   udp   4046  mountd
    100005    2   udp   4046  mountd
    100005    1   udp   4046  mountd
    100003    3   udp   2049  nfs
    100003    2   udp   2049  nfs
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
Comment 5 Ivan Valtchanov 2005-01-20 03:53:41 EST
   program vers proto   port
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100300    3   udp  32778  nisd
    100300    3   tcp  32772  nisd
    100303    1   tcp  32786  nispasswd
    100232   10   udp  32793  sadmind
    100083    1   tcp  32790
    100221    1   tcp  32791
    100068    2   udp  32794
    100068    3   udp  32794
    100068    4   udp  32794
    100068    5   udp  32794
    100229    1   tcp  32792
    100230    1   tcp  32793
    100242    1   tcp  32794
    100012    1   udp  32795  sprayd
    100011    1   udp  32796  rquotad
    100024    1   udp  32799  status
   100133    1   udp  32799
    100133    1   tcp  32795
    100021    1   udp   4045  nlockmgr
    100021    2   udp   4045  nlockmgr
    100021    3   udp   4045  nlockmgr
    100021    4   udp   4045  nlockmgr
    100021    1   tcp   4045  nlockmgr
    100021    2   tcp   4045  nlockmgr
    100021    3   tcp   4045  nlockmgr
    100021    4   tcp   4045  nlockmgr
    100249    1   udp  32847
    100249    1   tcp  32820
    300598    1   udp  32849
    300598    1   tcp  32821
 805306368    1   udp  32849
 805306368    1   tcp  32821
1289637086    5   tcp  32825
1289637086    1   tcp  32825
    100005    1   udp  35053  mountd
    100005    2   udp  35053  mountd
    100005    3   udp  35053  mountd
    100005    1   tcp  33971  mountd
    100005    2   tcp  33971  mountd
    100005    3   tcp  33971  mountd
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100227    2   udp   2049  nfs_acl
    100227    3   udp   2049  nfs_acl
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100227    2   tcp   2049  nfs_acl
    100227    3   tcp   2049  nfs_acl
Comment 6 C. Ray Ng 2005-01-20 08:58:57 EST
FWIW, I Rebuilt the src rpm quota-3.12-5 from Fedora Core 3 against a
RHEL3U4 system, replacing the installed quota-3.10-4. It then works fine.
Comment 7 Chris Feist 2005-01-20 09:31:54 EST
It appears that falling back to version 1 rquotad is broken in quota-3.09 (&
fixed in 3.10 and beyond).  I'm working on a fix.
Comment 8 Chris Feist 2005-01-25 17:19:41 EST
A fix was backported from quota-3.11 and built into quota-3.10-5
Comment 9 Chris Feist 2005-02-07 17:36:38 EST
*** Bug 147349 has been marked as a duplicate of this bug. ***
Comment 10 Chris Feist 2005-03-07 10:41:13 EST
Created attachment 111741 [details]
This patch fixes the incompatability with version 1 rquotad
Comment 11 Chris Feist 2005-03-30 12:00:18 EST
The fix is in quota-3.10-5 and later.
Comment 12 Chris Feist 2005-03-31 11:28:37 EST
You can obtain the quota-3.10-7 package to test with at
people.redhat.com/cfeist/quota/
Comment 13 Chris Feist 2005-03-31 11:28:57 EST
*** Bug 148853 has been marked as a duplicate of this bug. ***
Comment 18 Tim Powers 2005-05-19 14:06:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-351.html

Note You need to log in before you can comment on or make changes to this bug.