Bug 144128 - all videocards have DRIVER set to veas in anaconda
Summary: all videocards have DRIVER set to veas in anaconda
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhpl (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 132991
TreeView+ depends on / blocked
 
Reported: 2005-01-04 18:47 UTC by Jack Neely
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 14:28:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhpl diff (1.14 KB, text/plain)
2005-01-04 18:49 UTC, Jack Neely
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:191 normal SHIPPED_LIVE anaconda enhancement update 2005-05-18 04:00:00 UTC

Description Jack Neely 2005-01-04 18:47:43 UTC
Description of problem:
Under the Anaconda environment when rhpl is used to detect and setup
the videocard it always sets the DRIVER key of the dict to 'vesa'.

The code looks for the path

   "/usr/X11R6/%s/modules/drivers/%s_drv.o" %(libdir, card["DRIVER"])

to see if the X server module exists else it sets DRIVER to vesa.  In
the Anaconda environment the X modules are not installed therefore all
cards get the vesa driver.

Version-Release number of selected component (if applicable):
Install CDs from U3 and U4.  rhpl version 0.110.6-1.  

How reproducible:
Must use kickstart.

Comment 1 Jack Neely 2005-01-04 18:49:06 UTC
Created attachment 109341 [details]
rhpl diff

This is a diff between rhpl-0.110.6-1 and rhpl-0.110.4-1 which introduces this
bug.

Comment 2 Jeremy Katz 2005-03-02 18:42:22 UTC
Ugly-ish hack applied which should fix this problem while also keeping
the reason the change was made working as well.

Comment 3 Dennis Gregorovic 2005-05-18 14:28:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-191.html



Note You need to log in before you can comment on or make changes to this bug.