Bug 144205 - Linksys Wireless NIC not detected (WMP54G) PCI
Linksys Wireless NIC not detected (WMP54G) PCI
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 20:17 EST by Peter Quiring
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-06 20:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Quiring 2005-01-04 20:17:26 EST
Description of problem:
Linksys Wireless PIC-NIC Card (WMP54G) is not detected.

You probably want to see my lspci:
(you'll notice in there a Broadcom 802.11b/g controller.  Maybe 
that's what Linux thinks it is.  The Macronix controller is my wired 
NIC, it works fine.)

00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] 
System Controller (rev 13)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] 
AGP Bridge
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super 
South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 1a)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 1a)
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] 
(rev 40)
00:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g 
Wireless LAN Controller (rev 03)
00:0d.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 50)
00:0d.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 50)
00:0d.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
00:0e.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
00:0f.0 Ethernet controller: Macronix, Inc. [MXIC] MX987x5 (rev 20)
01:05.0 VGA compatible controller: Intel Corp. 82740 (i740) AGP 
Graphics Accelerator (rev 21)


iwconfig just shows "no wireless extensions" for "lo","eth0","sit0".

Version-Release number of selected component (if applicable):


How reproducible:
Everytime (even tried to reinstall FC3).

Steps to Reproduce:
1.install card
2.reboot
3.no detect
  
Actual results:
not detected

Expected results:
detected, config IP, SSID and go.

Additional info:
Comment 1 Sitsofe Wheeler 2005-01-05 12:08:48 EST
I'm a bit confused about what is wrong. A Linksys WMP54G uses a Broadcom chipset
(i.e. Linksys just branded Broadcom's hardware). This branding is quite common
with all hardware. You can check that here:
http://www.linux-wlan.org/docs/wlan_adapters.html.gz

Sadly there are no specs for Broadcom wireless chipsets (nor will Broadcom
release the specs due to one thing or another) so there are no open source
drivers and thus no way Fedora could support your hardware out of the box...
Comment 2 Peter Quiring 2005-01-08 13:55:23 EST
I've used the ndiswrapper (http://ndiswrapper.sourceforge.net) and it took a 
few days but it works.
Yes, I'm aware of "branding".  My dell laptop has a Dell wlan, but the drivers 
are almost the same as for the linksys one.
I'm happy enough to use the ndiswrapper for now.  Thanks.
Now I gotta get NAT routing done and I'm all set. ;)

Note You need to log in before you can comment on or make changes to this bug.