Bug 144284 - Logout button for xscreensaver
Logout button for xscreensaver
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xscreensaver (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 11:42 EST by Andreas Jonasson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Jonasson 2005-01-05 11:42:33 EST
Description of problem:


It would be really nifty if xscreensaver had a logout button. 

Students in our labs often lock their screens, leaving the computer
unsusable for long periods. Instilling the students with the fear of
god, or replacing xscreensaver with xlockmore requires more energy
then one might think.  


The xscreensaver FAQ mentions this problem.

http://www.jwz.org/xscreensaver/faq.html#logout-button

Since you have control over your platform I was hoping you could solve
the problem under Redhat Enterprise Linux.


Cheers,

Andreas Jonasson
Comment 1 Suzanne Hillman 2005-01-05 15:26:22 EST
Is there any reason that the keystrokes with which one can kill the X server
(thereby forcing it to restart itself if it's started automatically) is
insufficient?

(referring to <ctrl> <alt> <backspace>)
Comment 2 Andreas Jonasson 2005-01-13 09:08:43 EST
CTRL-ALT-backspace is a pretty good workaround. I can think of two problems
however:

- CTRL-ALT-backspace is not intuitive, it is a good tool for sysadms or
  teachers that need a quick and dirty way to kill X. We need to educate
  our users. Work for us that I hoped I could avoid.

- Assuming you know the trick of CTRL-ALT-backspace there is nothing that
  prevents you from throwing someone out at any time. A student should be 
  able to lock the screen for a couple of minutes while he gets his printouts
  from the printer. He should not be able to hog the computers for an hour
  while he goes for lunch.

Ideally we need the logout button because it is intuitive and that it appears
only when the machine has been locked for too long.


/Andreas
Comment 3 Suzanne Hillman 2005-01-13 10:52:04 EST
Internal RFE bug #144997 entered; will be considered for future releases.
Comment 4 Jamie Zawinski 2005-03-21 03:13:15 EST
4.21 has support for a "New Login" button (gdmflexiserver) on the lock dialog,
so maybe that'll be sufficient.  (Though on my machine, gdmflexiserver wedges X,
so this is not yet enabled by default.)
Comment 5 RHEL Product and Program Management 2007-10-19 15:09:56 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.