This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1443 - Upgrade conflict when upgrading from 4.2 wrt modules package.
Upgrade conflict when upgrading from 4.2 wrt modules package.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-07 03:57 EST by Harvey Stein
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-18 21:10:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harvey Stein 1999-03-07 03:57:26 EST
I just noticed on my system that upgrading from 4.2 to 5.2
caused a
modules problem.  I assume the same problem would occur with
upgrades
from 4.2 to any more recent redhat release.

The problem is that the modutils package used to be called
the modules
package.  The results after upgrade are:

   hjstein@bacall:~$ rpm -ql modules
   /sbin/depmod
   /sbin/genksyms
   /sbin/insmod
   /sbin/kerneld
   /sbin/ksyms
   /sbin/lsmod
   /sbin/modprobe
   /sbin/request-route
   /sbin/rmmod
   /usr/doc/modules-2.0.0-5
   /usr/doc/modules-2.0.0-5/README
   /usr/man/man1/depmod.1
   /usr/man/man1/insmod.1
   /usr/man/man1/ksyms.1
   /usr/man/man1/lsmod.1
   /usr/man/man1/modprobe.1
   /usr/man/man1/rmmod.1
   /usr/man/man2/modules.2
   /usr/man/man8/genksyms.8
   /usr/man/man8/kerneld.8
   hjstein@bacall:~$ rpm -ql modutils
   /etc/rc.d/init.d/kerneld
   /sbin/depmod
   /sbin/genksyms
   /sbin/insmod
   /sbin/insmod.static
   /sbin/kerneld
   /sbin/ksyms
   /sbin/lsmod
   /sbin/modinfo
   /sbin/modprobe
   /sbin/rmmod
   /sbin/rmmod.static
   /usr/man/man1/depmod.1
   /usr/man/man1/insmod.1
   /usr/man/man1/ksyms.1
   /usr/man/man1/lsmod.1
   /usr/man/man1/modinfo.1
   /usr/man/man1/modprobe.1
   /usr/man/man1/rmmod.1
   /usr/man/man2/create_module.2
   /usr/man/man2/delete_module.2
   /usr/man/man2/get_kernel_syms.2
   /usr/man/man2/init_module.2
   /usr/man/man2/query_module.2
   /usr/man/man8/genksyms.8
   /usr/man/man8/kerneld.8

Pretty ugly.

It looks like RPM spec files need a 'Replaces:' keyword to
record that
a given package actually replaces one or more other
packages.  Either
that or build the info into the installer...
Comment 1 Cristian Gafton 1999-03-18 21:10:59 EST
Fixed in the beta tree

Note You need to log in before you can comment on or make changes to this bug.